Ask Your Question
0

Openni2 is 'No matching device found' with Kinect One(v2)

asked 2019-03-11 04:11:08 -0600

A_YIng gravatar image

Hello,

I use Kinect One(v2) with my ROS project, so I already installed iai_kinect2 and libfreenect2.

This works fine to me.

However, I want to use openni with my Kinect device, and it show me 'No matching device found'.

roslaunch openni2_launch openni2.launch
... logging to /home/cyc/.ros/log/75743bc6-43db-11e9-ba90-9c5c8e1afee7/roslaunch-cyc-X550JX-10898.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://cyc-X550JX:46521/

SUMMARY
========

PARAMETERS
 * /camera/camera_nodelet_manager/num_worker_threads: 4
 * /camera/depth_rectify_depth/interpolation: 0
 * /camera/driver/color_depth_synchronization: False
 * /camera/driver/color_mode: 5
 * /camera/driver/depth_camera_info_url: 
 * /camera/driver/depth_frame_id: camera_depth_opti...
 * /camera/driver/depth_mode: 5
 * /camera/driver/depth_registration: False
 * /camera/driver/device_id: #1
 * /camera/driver/id_manufacturer: 1d27
 * /camera/driver/id_product: 0601
 * /camera/driver/ir_mode: 5
 * /camera/driver/rgb_camera_info_url: 
 * /camera/driver/rgb_frame_id: camera_rgb_optica...
 * /rosdistro: kinetic
 * /rosversion: 1.12.14

NODES
  /camera/
    camera_nodelet_manager (nodelet/nodelet)
    depth_metric (nodelet/nodelet)
    depth_metric_rect (nodelet/nodelet)
    depth_points (nodelet/nodelet)
    depth_rectify_depth (nodelet/nodelet)
    depth_registered_sw_metric_rect (nodelet/nodelet)
    driver (nodelet/nodelet)
    points_xyzrgb_sw_registered (nodelet/nodelet)
    register_depth_rgb (nodelet/nodelet)
    rgb_rectify_color (nodelet/nodelet)
  /
    camera_base_link (tf2_ros/static_transform_publisher)
    camera_base_link1 (tf2_ros/static_transform_publisher)
    camera_base_link2 (tf2_ros/static_transform_publisher)
    camera_base_link3 (tf2_ros/static_transform_publisher)

ROS_MASTER_URI=http://localhost:11311

process[camera/camera_nodelet_manager-1]: started with pid [10915]
process[camera/driver-2]: started with pid [10916]
process[camera/rgb_rectify_color-3]: started with pid [10917]
process[camera/depth_rectify_depth-4]: started with pid [10919]
process[camera/depth_metric_rect-5]: started with pid [10936]
process[camera/depth_metric-6]: started with pid [10944]
process[camera/depth_points-7]: started with pid [10962]
process[camera/register_depth_rgb-8]: started with pid [10977]
process[camera/points_xyzrgb_sw_registered-9]: started with pid [10991]
process[camera/depth_registered_sw_metric_rect-10]: started with pid [11004]
process[camera_base_link-11]: started with pid [11019]
[ INFO] [1552294584.856946808]: Initializing nodelet with 4 worker threads.
process[camera_base_link1-12]: started with pid [11045]
process[camera_base_link2-13]: started with pid [11066]
process[camera_base_link3-14]: started with pid [11080]
[ INFO] [1552294584.945483093]: No matching device found.... waiting for devices. Reason: std::__cxx11::string openni2_wrapper::OpenNI2Driver::resolveDeviceURI(const string&) @ /tmp/binarydeb/ros-kinetic-openni2-camera-0.4.2/src/openni2_driver.cpp @ 737 : Invalid device number 1, there are 0 devices connected.

I have tried everything I can try, but still doesn't work.

Anyone know that? Please help me.

Thanks a lot.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2019-03-13 04:20:59 -0600

A_YIng gravatar image

updated 2019-03-13 04:22:04 -0600

I found a solution by myself, and hope it could help you guys !

1.Follow this tutorials to install libfreenect if you use kinect v2.

2.Run the test openni step in the last line.

sudo apt-get install openni2-utils && sudo make install-openni2 && NiViewer2

If you install successfully, it will show you a depth image and raw image in a window.

3.Run the openni2 launch

roslaunch openni2_launch openni2.launch

You will see these error message and just ignore them.

[ERROR] [1552467844.769017052]: Unsupported IR video mode - Resolution: 640x480@30Hz Format: Gray16
[ERROR] [1552467844.769132239]: Unsupported color video mode - Resolution: 640x480@30Hz Format: RGB888
[ERROR] [1552467844.769336219]: Could not set auto exposure. Reason: void openni2_wrapper::OpenNI2Device::setAutoExposure(bool) @ /home/cyc/catkin_ws/src/openni2_camera/openni2_camera/src/openni2_device.cpp @ 549 : Couldn't set auto exposure: 
    Stream setProperty(101) failed



[ERROR] [1552467844.769386920]: Could not set auto white balance. Reason: void openni2_wrapper::OpenNI2Device::setAutoWhiteBalance(bool) @ /home/cyc/catkin_ws/src/openni2_camera/openni2_camera/src/openni2_device.cpp @ 565 : Couldn't set auto white balance: 
    Stream setProperty(100) failed



[ERROR] [1552467844.769438262]: Could not set exposure. Reason: void openni2_wrapper::OpenNI2Device::setExposure(int) @ /home/cyc/catkin_ws/src/openni2_camera/openni2_camera/src/openni2_device.cpp @ 582 : Couldn't set exposure: 
    Stream setProperty(102) failed

This mean kinect v2 with openni do not support those function,but it didn't influence my project. If anyone know how to fix it, please add it.

4.View in Rviz

image description

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-03-11 04:11:08 -0600

Seen: 628 times

Last updated: Mar 13 '19