ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A
Ask Your Question

ERROR: cannot launch node of type : can't locate node in package

asked 2019-01-17 06:18:39 -0600

QLTech gravatar image

updated 2019-01-17 08:07:12 -0600

gvdhoorn gravatar image

I have installed Ubuntu 18 04 and ROS melodic. I have installed moveit using these instructions:

Te section i have linked instructs the following:

Open two shells. In the first shell start RViz and wait for everything to finish loading:

roslaunch panda_moveit_config demo.launch

In the second shell, run the launch file:

roslaunch moveit_tutorials move_group_interface_tutorial.launch

The second instruction failed with:

ERROR: cannot launch node of type [moveit_tutorials/move_group_interface_tutorial]: can't locate node [move_group_interface_tutorial] in package [moveit_tutorials]

If i do :

rosrun moveit_tutorials

and tab for autocomplete i don't see the 'move_group_interface_tutorial node'.

I get:                    

I ran:

locate move_group_interface_tutorial

here is the output:


I have 2 workspaces. I created this workspace specifically for moveit!.

here is the text i ahve added to my .bashrc

# added by A Wilson to .bashrc file
source /opt/ros/melodic/setup.bash
source /home/anthony/catkin_ws/devel/setup.bash
source /home/anthony/ws_moveit/devel/setup.bash
source /home/anthony/catkin_ws/src/MYNT-EYE-S-SDK/wrappers/ros/devel/setup.bash
export ROS_PACKAGE_PATH=/home/anthony/catkin_ws/src/MYNT-EYE-S-SDK/wrappers/ros/src:/home/anthony/catkin_ws/src:/opt/ros/melodic/share:/home/anthony/catkin_ws/src/MYNT-EYE-ORB-SLAM2-Sample/Examples/ROS/ORB_SLAM2:/home/anthony/ws_moveit/src

echo "ROS package path:" $ROS_PACKAGE_PATH

if i do:

locate move_group_interface_tutorial

I ran locate

edit retag flag offensive close merge delete


I have a similar constellation: ROS Melodic and Ubuntu 18.04 and trying to run a YDLidar X2. When I do the command: "roslaunch ydlidar_ros_driver X2.launch" I get these error message.

Therefore I did "roslaunch-logs": roslaunch][INFO] 2020-12-10 11:21:10,246: Checking log directory for disk usage. This may take a while. Press Ctrl-C to interrupt [roslaunch][INFO] 2020-12-10 11:21:10,261: Done checking log file disk usage. Usage is <1GB. [roslaunch][INFO] 2020-12-10 11:21:10,262: roslaunch starting with args ['roscore', '--core'] [roslaunch][INFO] 2020-12-10 11:21:10,263: roslaunch env is {'ROS_DISTRO': 'melodic', 'MATE_DESKTOP_SESSION_ID': 'this-is-deprecated', 'XDG_GREETER_DATA_DIR': '/var/lib/lightdm-data/robert', 'PKG_CONFIG_PATH': '/opt/ros/melodic/lib/pkgconfig', 'XDG_RUNTIME_DIR': '/run/user/1000', 'XDG_CURRENT_DESKTOP': 'MATE', 'XDG_SESSION_TYPE': 'x11', 'LOGNAME': 'robert', 'USER': 'robert', 'ROS_PACKAGE_PATH': '/home/robert/ydlidar_ws/src:/opt/ros/melodic/share', 'XDG_VTNR':

Tricia279 gravatar image Tricia279  ( 2020-12-10 06:05:40 -0600 )edit

That is not the whole logfile, but I real don't know where the ERROR occures from. [roslaunch][INFO] 2020-12-10 11:21:14,362: ... successfully launched [rosout-1] [roslaunch][INFO] 2020-12-10 11:21:14,364: load_parameters starting ... [roslaunch][INFO] 2020-12-10 11:21:14,380: ... load_parameters complete [roslaunch][INFO] 2020-12-10 11:21:14,381: launch_nodes: launching local nodes ... [roslaunch][INFO] 2020-12-10 11:21:14,382: ... launch_nodes complete [roslaunch.pmon][INFO] 2020-12-10 11:21:14,382: registrations completed That is the part with the nodes. Did anyone has an idea how to find a solution ? I real appreciate your answers.

Tricia279 gravatar image Tricia279  ( 2020-12-10 06:12:32 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2019-01-18 05:43:25 -0600

QLTech gravatar image

I worked around this by adding a symbolic link to the file location in the devel directory

edit flag offensive delete link more



You seem to be sourceing multiple workspaces. Unless those workspaces are overlays (and in the order listed in your .bashrc that you show, that is not going to work.

All Catkin workspaces are stand-alone and you can only have a single one active at a time.

If you need multiple workspaces, ..

gvdhoorn gravatar image gvdhoorn  ( 2019-01-18 05:55:12 -0600 )edit

.. and want/need packages from all of those, look into workspace overlaying.

Making symlinks between workspaces is not a good idea.

gvdhoorn gravatar image gvdhoorn  ( 2019-01-18 05:56:01 -0600 )edit

Thanks. Although im sure you are right i dont thibk that is why i have the problem. I have 2 workspaces, catkin_ws and ws_moveit. I did try removing catkin_ws and only sourcing ws_moveit (the one with issue). This made no difference till i created the symbolic link.

QLTech gravatar image QLTech  ( 2019-01-18 08:07:27 -0600 )edit

Hey Jan, what exactly is a symbolic link and where did you add it to?

macrot51 gravatar image macrot51  ( 2019-08-14 04:09:09 -0600 )edit

i have the same problem i fixed it by removing the workspace that containing the same node

houssem trabelsi gravatar image houssem trabelsi  ( 2019-08-22 23:50:24 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools


Asked: 2019-01-17 06:18:39 -0600

Seen: 7,553 times

Last updated: Jan 18 '19