Ask Your Question
0

Problem running pick and place application tutorial

asked 2012-04-04 18:06:39 -0500

alexanderjyuen gravatar image

Hi

I am trying to run the tutorial in

http://devel.iri.upc.edu/docs/roswiki/pr2_tabletop_manipulation_apps%282f%29Tutorials%282f%29Writing%2820%29a%2820%29Simple%2820%29Pick%2820%29and%2820%29Place%2820%29Application.html

However, I get an error saying: Call to segmentation service failed

This occurs when it looks for the tabletop in the very beginning. Any help would be appreciated, thanks in advance

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-02-17 16:13:36 -0500

hsiao gravatar image

Is the robot looking at the table/object? Segmentation won't succeed otherwise. If you're in Fuerte or Groovy, you can use interactive manipulation to position your robot, see http://www.ros.org/wiki/pr2_pick_and_place_demos/Tutorials/The%20Pick%20and%20Place%20Autonomous%20Demo/

Also, this shouldn't have been a problem back in April 2012, but recently if you were using Fuerte + Kinect, there was a launch misconfiguration that was killing segmentation that is now fixed.

Sorry not to answer in a very timely fashion. All my ROS answers emails were getting spam-filtered. :P

edit flag offensive delete link more

Comments

I've got the same problem recently, but there was no such problem before. The default setting is to use the stereo camera and I've write a simple node to make PR2 look down. But the problem still exists. How to fix this problem? Thanks

Albert K gravatar image Albert K  ( 2013-05-24 17:20:13 -0500 )edit

You're using the stereo camera and looking at the table and it says Call to segmentation service failed? Any other error messages around it? Which ROS distro are you using?

hsiao gravatar image hsiao  ( 2013-05-25 11:30:42 -0500 )edit

I've checked the pr2_tabletop_manipulation.launch, and the value of arg stereo is true, which will set thetabletop_segmentation_points_input as narrow_stereo_textured/points2. I put the error messages here: http://notepad.cc/dedoucle19 and the brief description is below. My ROS distro is Fuerte

Albert K gravatar image Albert K  ( 2013-05-25 21:21:08 -0500 )edit

The object segmentation service can segment out the table. The INFO shows that "Step 4 done" and "Table computed". But after that, there seemed to be some internal problems which threw out the error message "Call to segmentation service failed", and then the tabletop_segmentation node died.

Albert K gravatar image Albert K  ( 2013-05-25 21:24:58 -0500 )edit

Hrm. That's odd. Fuerte debians, latest version? Are you using shadow-fixed or public repos? What version of Ubuntu? 64-bit or 32-bit? I just tried using pr2_table_object.launch, both stereo:=true and stereo:=false, and both worked fine on my laptop.

hsiao gravatar image hsiao  ( 2013-05-28 17:55:28 -0500 )edit

There have been some build-farm compilation issues with compile flags lately, that might be causing the undefined-symbol problems you're seeing. Try just compiling and using object_manipulation and pr2_object_manipulation from source.

hsiao gravatar image hsiao  ( 2013-05-28 17:58:27 -0500 )edit

I'm using Fuerte on Ubuntu 12.04 64-bit and the package is installed using apt-get. I've already upgrade all the package to the latest version. I don't know what is the difference between using shadow-fixed or public repos. Also, what is build-farm compilation issues with compile flags lately mean?

Albert K gravatar image Albert K  ( 2013-05-30 18:01:39 -0500 )edit

I'm guessing you're using the public repos (http://packages.ros.org/ros/ubuntu) then. When http://ros.org/debbuild/fuerte.html shows FbinP64 for perception_pcl having a green box (mouseover the green box should read ros/Public 1.2.4) then the new release of perception_pcl will be done building.

hsiao gravatar image hsiao  ( 2013-05-30 19:02:06 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-04-04 18:06:39 -0500

Seen: 300 times

Last updated: Feb 17 '13