Ask Your Question
1

ROS fuerte PCL tutorial problem

asked 2013-08-06 04:06:03 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Hello,

I followed the ROS PCL tutorial. (How to use a PCL tutorial in ROS) I could build the package successfully with rosmake.

I enter

rosrun my_pcl_tutorial example input:=/narrow_stereo_textured/points2

Nothing is happening. I do not get an error message. I tried both of the tutorials. I know that program is running (as I add a rosinfo, I can see the message) but cant I display the view in anywhere. I mean, won't I see something like the video in the referred PCL tutorial page?

Btw I changed the input:=/narrow_stereo_textured/points2 with the topic in rviz.I had no clue what that is before. Thanks :)

Edit: Now I do not have any problem left, everything is working in tutorial. The only question is: in the ros pcl tutorial page, links to pcl tutorial of the same codes are given. Those tutorials have their videos which show the point cloud view, you should have once you run the code. So, when I run the code in Ros, message is sent. Everything is working but I expect to see a point cloud view. All in all, what this code is really supposed to do is applying a filter, not just send messages, right? So my question is, is there a way to view what the code we run is actually doing?

edit retag flag offensive close merge delete

Comments

1

`rostopic list` will show what topics are actually being advertised, and `rostopic hz /narrow_stereo_textured/points2` will tell you if anything is being published on that topic.

joq gravatar image joq  ( 2013-08-06 07:09:09 -0500 )edit
1

So everything with the ros pcl tutorial is working fine? That's good to hear. I don't understand what your question is, if the problem is that you are seeing a black box in the space where there is supposed to be a video the you probably need to update your flash player or something as they should be working fine. If that doesn't work, try a different browser or if your using ubuntu in a virtual machine then try using a browser outside virtual machine.

Loufis gravatar image Loufis  ( 2013-08-07 08:14:01 -0500 )edit

My question is, is not this code supposed to do something more than showing me black terminal? I mean it sends message and stuff. That is all good. It is working. But I mean I expected to see the point cloud view since its aim is running a filter in ros? Wont I see a point cloud, when it runs?

mary gravatar image mary  ( 2013-08-08 00:30:08 -0500 )edit

Thanks alot =)

mary gravatar image mary  ( 2013-08-09 01:56:03 -0500 )edit

If you are doing the Point Clouds 2 part of the tutorial where you are applying a voxel grid filter then yes, it does publish data that you can view through rviz, just add a new Point Clouds 2 and set the topic to /output

Loufis gravatar image Loufis  ( 2013-08-09 10:39:26 -0500 )edit

I am having the same issue. I'm just trying to follow the tutorial on ros-groovy, rosbuild. I run roscore and then run that line and then nothing. The code seems to run, I don't get an error or a new cursor entry. I went so far as to follow the exact path Loufis stated and still nothing

catroscoder gravatar image catroscoder  ( 2013-08-20 05:34:05 -0500 )edit

When I run the tutorial I add a camera and a PointCloud2 in rviz and I see something but I don't know if the images that i see are correct because in one PointCloud2 I see the image but I don't know if it have the VoxelGrid Filter of this tutorial.

App gravatar image App  ( 2013-09-26 03:50:10 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-08-06 05:35:44 -0500

Loufis gravatar image

updated 2013-08-06 10:20:59 -0500

Hi, what exactly do u mean it's not working, does it give you a specific error? does it have no output?

Here are a few common errors people do while using this tutorial:

  • Forgetting to run roscore (very common mistake for beginners).

  • Did not source their files (making ros unable to recognize it as a stack/package)

  • Use input:=/narrow_stereo_textured/points2 even though that input is specific to a certain type of camera which might not be yours. What kind of camera are you using? If it's a kinect for example then you would want to use input:=/camera/depth_registered/points

  • Are you trying the tutorial one for Point Clouds or Point Clouds 2? The one for Point Clouds does not publish images you can view, while the one for Point Clouds 2 publishes a message of type Point Clouds 2 (if you are trying to view it in rviz make sure that's the type you have chosen to view it).

If none of these are your problem then please give us some more information so that we may be able to understand your problem better.

edit flag offensive delete link more

Comments

For future problems, a very helpful way of debugging in ros is using rqt_graph, it helps you understand what exactly is happening in the background (is the program subscribed correctly to all the inputs? does it publish everything correctly? if using a series of nodes, where do they stop working? etc...)

Loufis gravatar image Loufis  ( 2013-08-06 05:44:51 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2013-08-06 04:06:03 -0500

Seen: 483 times

Last updated: Aug 08 '13