openni_tracker crashes upon launching [closed]

asked 2012-04-04 05:43:56 -0600

Haikal Pribadi gravatar image

Hi everybody.. When I run openni_tracker, often (not always) it may not launch. Sometimes it simply says segmentation fault, or InitFromXml failed: Can't create any node of the requested type!. It happens more often when I run it from roslaunch: it says openni_tracker process has died . What makes things harder is that nothing is recorded in the log. I know this is a similar discussion to this. But I have checked that the openni_tracker.xml do exist in the package root. I'm completely clueless and frustrated with this.

1. How could this problem be solved?
2. How do we check if a process has died from within one of ROS's nodes, and reactivate that node that has died?

Thank you, everyone.

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2014-05-15 13:12:47

Comments

anyone?? no one?? ....

Haikal Pribadi gravatar imageHaikal Pribadi ( 2012-04-06 09:06:39 -0600 )edit