Ask Your Question
1

rviz crashes when used with pr2 navigation [closed]

asked 2014-03-13 13:04:24 -0600

sonyaa gravatar image

updated 2014-04-04 09:03:46 -0600

I'm trying to launch the navigation stack for the pr2. Here's what I run:

  1. rosrun map_server map_server basement_map.yaml
  2. roslaunch pr2_navigation_global rviz_move_base.launch
  3. (on the robot) roslaunch pr2_2dnav pr2_2dnav.launch

After I launch the 2dnav on the robot, the robot model appears in rviz. After about 10 seconds the red markers for obstacles appear and rviz crashes immediately. Usually it doesn't give an error message but sometimes there's also this message:

*** glibc detected *** /opt/ros/groovy/lib/rviz/rviz: free(): corrupted unsorted chunks: 0x000000000280e750 ***
======= Backtrace: =========
/lib/x86_64-linux-gnu/libc.so.6(+0x7eb96)[0x7fd273539b96]
/opt/ros/groovy
<....>

(there's a lot more text, here's the full error message: pastebin.com/ArwKkirr)

Sometimes the message looks similar, but starts with "corrupted double linked list" or "malloc error".

The same thing happens if I launch pr2_interactive_manipulation with navigation enabled (without navigation everything is fine).

I'm using Ubuntu 12.04, Nvidia driver 331 (I also tried it with 304 and with a generic driver, same thing happens).

Update: seems that the problem is caused by GridCells visualization. If I start with a fresh rviz ("rosrun rviz rviz") and add navigation-related topics one by one, rviz crashes after GridCells are added with a non-empty topic (for example, "/move_base_node/local_costmap/obstacles")

Update 2: Another way for rviz to crash turned out to be adding DepthCloud with a non-empty DepthMap topic (for example, "/head_mount_kinect/depth_registered/image").

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by sonyaa
close date 2014-04-04 10:10:00

Comments

Just a longshot: are you possibly mixing different ROS versions? Or different versions of boost? Otherwise, could be a bug in the GridCells display and it might be worth filing a bug report.

demmeln gravatar image demmeln  ( 2014-04-04 00:22:40 -0600 )edit

Thanks for the suggestion! The versions of ROS and boost are the same on the robot and the machine I'm running rviz from. I've also just discovered one more way to make rviz crash (see update).

sonyaa gravatar image sonyaa  ( 2014-04-04 09:02:11 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2014-04-04 09:24:04 -0600

BP gravatar image

updated 2014-04-04 09:25:10 -0600

This is probably an rviz bug that they fixed. I suggest download and build new version of rviz or try to run old one with optirun if You can( that can fix few bugs but not all). U can read more about this :

my question

issue on official repo

edit flag offensive delete link more

Comments

Thank you! I installed a new version of rviz (1.9.35) and that worked.

sonyaa gravatar image sonyaa  ( 2014-04-04 10:09:04 -0600 )edit

I'm glad I could help :)

BP gravatar image BP  ( 2014-04-04 10:20:28 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2014-03-13 13:04:24 -0600

Seen: 246 times

Last updated: Apr 04 '14