Ask Your Question
1

Segfault in fuerte stageros

asked 2012-10-16 18:41:43 -0600

kbogert gravatar image

updated 2012-10-17 07:27:46 -0600

I'm seeing a consistent segfault in stageros on startup seemingly related to blocks. If I remove the block portion of the robot definition it does load but the robot doesn't get hit by laser strikes. I am running Ubuntu 12.04 32bit, and am seeing the same crashes on computers with both AMD and Nvidia GPU's.

The following gdb output was generated while trying to run the roomba_stage tutorial at: https://kforge.ros.org/navigation/tutorials/file/d1f3dda4fd5a/roomba_stage

The segfault occurs in: /usr/lib/i386-linux-gnu/libGLU.so


Starting program: /opt/ros/fuerte/stacks/stage/bin/stageros /home/ros/fuerte_workspace/navigation_tutorials/roomba_stage/roomba_lse_arena.world
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[New Thread 0x42720b40 (LWP 7706)]
[New Thread 0x42921b40 (LWP 7707)]
[New Thread 0x42d00b40 (LWP 7708)]
[New Thread 0x43200b40 (LWP 7715)]
[New Thread 0x4516db40 (LWP 7719)]
 [Loading /home/ros/fuerte_workspace/navigation_tutorials/roomba_stage/roomba_lse_arena.world][New Thread 0x45bcab40 (LWP 7720)]
[Image "./maps/lse_arena.pgm"]
warn: worldfile /home/ros/fuerte_workspace/navigation_tutorials/roomba_stage/roomba_lse_arena.world:22 : property [laser_return] is defined but not used (/tmp/buildd/ros-fuerte-stage-1.6.6/debian/ros-fuerte-stage/opt/ros/fuerte/stacks/stage/build/stage/libstage/worldfile.cc WarnUnused)
warn: worldfile /home/ros/fuerte_workspace/navigation_tutorials/roomba_stage/roomba_lse_arena.world:32 : property [color] is defined but not used (/tmp/buildd/ros-fuerte-stage-1.6.6/debian/ros-fuerte-stage/opt/ros/fuerte/stacks/stage/build/stage/libstage/worldfile.cc WarnUnused)
warn: worldfile /home/ros/fuerte_workspace/navigation_tutorials/roomba_stage/roomba_lse_arena.world:8 : property [range_max] is defined but not used (/tmp/buildd/ros-fuerte-stage-1.6.6/debian/ros-fuerte-stage/opt/ros/fuerte/stacks/stage/build/stage/libstage/worldfile.cc WarnUnused)
warn: worldfile /home/ros/fuerte_workspace/navigation_tutorials/roomba_stage/roomba_lse_arena.world:7 : property [range_min] is defined but not used (/tmp/buildd/ros-fuerte-stage-1.6.6/debian/ros-fuerte-stage/opt/ros/fuerte/stacks/stage/build/stage/libstage/worldfile.cc WarnUnused)
[ INFO] [1350446716.598520044]: found 1 position/laser pair in the file
[New Thread 0x45dcbb40 (LWP 7727)]

Program received signal SIGSEGV, Segmentation fault.
0x4097c793 in __gl_pqSortInit (pq=0x843f9f8) at libtess/priorityq.c:132
132       j = r + 1;
(gdb) bt
#0  0x4097c793 in __gl_pqSortInit (pq=0x843f9f8) at libtess/priorityq.c:132
#1  0x4097fb2e in InitPriorityQ (tess=< optimized out>) at libtess/sweep.c:1251
#2  __gl_computeInterior (tess=0x8666078) at libtess/sweep.c:1321
#3  0x40980900 in gluTessEndPolygon (tess=0x8666078) at libtess/tess.c:540
#4  0x40273d55 in Stg::BlockGroup::BuildDisplayList (this=0x864a6d4) at /tmp/buildd/ros-fuerte-stage-1.6.6/debian/ros-fuerte-stage/opt/ros/fuerte/stacks/stage/build/stage/libstage/blockgroup.cc:243
#5  0x40274155 in Stg::BlockGroup::CallDisplayList (this=0x864a6d4) at /tmp/buildd/ros-fuerte-stage-1.6.6/debian/ros-fuerte-stage/opt/ros/fuerte/stacks/stage/build/stage/libstage/blockgroup.cc:288
#6  0x4028857e in Stg::Model::DrawBlocks (this=0x864a678) at /tmp/buildd/ros-fuerte-stage-1.6.6/debian/ros-fuerte-stage/opt/ros/fuerte/stacks/stage/build/stage/libstage/model_draw.cc:253
#7  0x402889b2 in Stg::Model::DrawBlocksTree (this=0x864a678) at /tmp/buildd/ros-fuerte-stage-1.6.6/debian/ros-fuerte-stage/opt/ros/fuerte/stacks/stage/build/stage/libstage/model_draw.cc:235
#8  0x402adc73 in Stg::Canvas::DrawBlocks (this=0x80bbfd0 ...
(more)
edit retag flag offensive close merge delete

Comments

This doesn't appear to have anything to do with the rangers issue in: http://answers.ros.org/question/33973/stage-error-in-fuerte/?answer=34967#post-id-34967

kbogert gravatar imagekbogert ( 2012-10-17 07:25:53 -0600 )edit

Do other world files launch without issue?

SL Remy gravatar imageSL Remy ( 2012-10-17 07:35:40 -0600 )edit

Yes it has to do with rangers. Your world file define a laser but in stage 4.0 there are no more laser devices. They are all rangers now.

Pablo Urcola gravatar imagePablo Urcola ( 2012-10-18 02:58:35 -0600 )edit

I've tried other worlds and they have the same issue. Pablo stop, if you'd look at the world file I'm launching you'd see that it has changed all the Laser's to Rangers.

kbogert gravatar imagekbogert ( 2012-10-19 08:22:22 -0600 )edit

Note that if I run stage with the -g option to disable graphics this crash is avoided

kbogert gravatar imagekbogert ( 2012-10-19 08:41:04 -0600 )edit

to be clear, you're using an NVIDIA card and this isn't a virtual card correct?

SL Remy gravatar imageSL Remy ( 2012-10-19 17:22:16 -0600 )edit

It would be easier to help you if you post hear your world file, of course. But I can see 4 warning messages in your trace that are related to the new syntax for lasers. I recommend you to fix them just to be sure that the problem is not there.

Pablo Urcola gravatar imagePablo Urcola ( 2012-10-21 21:32:07 -0600 )edit

3 Answers

Sort by ยป oldest newest most voted
0

answered 2012-12-12 16:15:18 -0600

kbogert gravatar image

It appears the problem is that in the stage world files the block sections are missing the z parameter. See: https: //github.com/rtv/Stage/issues/31

So I prevented the crash by adding:

z [0 .32]

to the stage world file's block section linked in the original question up top.

edit flag offensive delete link more
0

answered 2012-10-16 22:49:33 -0600

edit flag offensive delete link more
0

answered 2013-01-25 03:36:18 -0600

HammyG gravatar image

I had a similar issue with stage throwing a SegFault with an old world file (even after updating laser -> ranger).

The cause was (as mentioned by kbogert) the Z dimension was set to 0 on the robot.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-10-16 18:41:43 -0600

Seen: 493 times

Last updated: Jan 25 '13