Ask Your Question
0

Getting android_tutorial_pubsub connected to the roscore on PC (crash)

asked 2012-04-06 04:21:58 -0500

alexbeta20 gravatar image

I am trying to modify the android_tutorial_pubsub to let it connect to the roscore on computer so I can establish communications between them. I successfully build the tutorial and I am able to see the "Hello world n" on screen. However, the tutorial is building its own roscore in the phone by default, so I tried to find some solutions to modify it and I found a patch file. (http://ias.in.tum.de/~moesenle/android_tutorial_pubsub.patch). After changing my code manually, it is compiled within eclipse IDE successfully. However, when the app launches on the phone, after I enter the http://localhost:11311/ and click OK, it crashes. It gives the following error in the log cat. FATAL EXCEPTION: pool-1-thread-1. I tried to debug the app but failed. I hope that anyone could help me. Thanks.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2012-04-06 05:13:42 -0500

jbohren gravatar image

If you use Lorenz's patch, then you need to actually start a master at the URI that you specify. If you're connecting to the roscore on a PC on the network, you need to put in that URI and not "localhost".

When I run Lorenz's patch with the URI set to localhost, it doesn't crash, but it also doesn't do anything. This is expected, since I'm not running a roscore on the tablet.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-04-06 04:21:58 -0500

Seen: 284 times

Last updated: Apr 06 '12