Ask Your Question
1

NiTE v1.5.2.23 not detected: NITE is likely missing

asked 2016-02-08 00:34:08 -0600

adelleodel gravatar image

it's so weird that everytime i want to run openni_tracker rosrun openni_tracker openni_tracker such in KinectWithROSTutorial.pdf that i have, at terminal it always shown up:

[ERROR] [1454912600.620223128]: NITE is likely missing: Please install NITE >= 1.5.2.21. Check the readme for download information. Error Info: User generator failed: Can't create any node of the requested type!

eventough i have install NiTE v1.5.2.23 with tutorial in here. and also try download it from the link in README files that mention in terminal. the thing is, i've succeed run the example of the nite which mention in tutorial there. but it failed when i run openni_tracker.

i also succeed roslaunch openni_launch openni.launch and tried rosrun image_view image_view image:=/camera/rgb/image_color.

so what's wrong with my program then?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-06-26 07:43:01 -0600

SaiBot gravatar image

The problem is with your NiTE installation. Your number version might be correct, but you must be using wrong architecture, i.e. ARM instead of x64/x86. Therefore, git clone the following and install NiTE again, it should work.

https://github.com/arnaud-ramey/NITE-...

I have been facing this issue for a while, I can most definitely say the problem is with NiTE installation. If the above doesn't work, try installing it again.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-02-08 00:34:08 -0600

Seen: 712 times

Last updated: Jun 26 '18