Problems when installing pcl library in ROS Indigo

asked 2018-12-09 01:51:52 -0500

Xiang gravatar image

updated 2018-12-09 01:59:35 -0500

Hi all,

I am trying to install the point cloud library in ROS Indigo, Ubuntu 14.04. I tried several different ways, but no one works.

First, I created the package in a workspace, followed here, and execute the command showed here

rosdep install --from-paths ~/Documents/Projects/catkin_ws/src/my_pcl_tutorial --ignore-src -r --rosdistro indigo -y

However, it shows this

ERROR: the following packages/stacks could not have their rosdep keys resolved
to system dependencies:
my_pcl_tutorial: No definition of [libpcl-all] for OS version []
Continuing to install resolvable dependencies...
executing command [sudo -H apt-get install -y libpcl-dev]
[sudo] password for alex: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package libpcl-dev
ERROR: the following rosdeps failed to install
  apt: command [sudo -H apt-get install -y libpcl-dev] failed
  apt: Failed to detect successful installation of [libpcl-dev]

The problem remains if I execute

sudo add-apt-repository ppa:v-launchpad-jochen-sprickerhof-de/pcl
sudo apt-get update

I also followed the answer here, the same problem occurred. I was confused that I thought it should install libpcl-all, but not libpcl-dev, because I was in Ubuntu 14.04, Indigo.

Then, I tried to follow the instructions from the pcl official site. Remove /etc/apt/sources.list.d/v-launchpad-jochen-sprickerhof-de-*, and execute

sudo add-apt-repository ppa:v-launchpad-jochen-sprickerhof-de/pcl
sudo apt-get update
sudo apt-get install libpcl-all

After that, I 'catkin_make' in my workspace where I created a pcl package like this, but it shows 'Could not find a package configuration file provided by "pcl_conversions'.

Can anyone please help me to solve the problem? many thanks.

-- Using CATKIN_DEVEL_PREFIX: /home/alex/Documents/Projects/catkin_ws/devel
-- Using CMAKE_PREFIX_PATH: /home/alex/Documents/Projects/rgbdslam_ws/devel;/opt/ros/indigo
-- This workspace overlays: /home/alex/Documents/Projects/rgbdslam_ws/devel;/opt/ros/indigo
-- Using PYTHON_EXECUTABLE: /home/alex/anaconda2/bin/python
-- Using Debian Python package layout
-- Using empy: /usr/bin/empy
-- Using CATKIN_ENABLE_TESTING: ON
-- Call enable_testing()
-- Using CATKIN_TEST_RESULTS_DIR: /home/alex/Documents/Projects/catkin_ws/build/test_results
-- Found gtest sources under '/usr/src/gtest': gtests will be built
-- Using Python nosetests: /usr/bin/nosetests-2.7
-- catkin 0.6.19
-- BUILD_SHARED_LIBS is on
-- ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-- ~~  traversing 4 packages in topological order:
-- ~~  - beginner_tutorials
-- ~~  - my_pcl_tutorial
-- ~~  - bag_generator
-- ~~  - tiny_slam
-- ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-- +++ processing catkin package: 'beginner_tutorials'
-- ==> add_subdirectory(beginner_tutorials)
-- Using these message generators: gencpp;genlisp;genpy
CMake Warning at /home/alex/Documents/Projects/catkin_ws/build/beginner_tutorials/cmake/beginner_tutorials-genmsg.cmake:3 (message):
  Invoking generate_messages() without having added any message or service
  file before.

  You should either add add_message_files() and/or add_service_files() calls
  or remove the invocation of generate_messages().
Call Stack (most recent call first):
  /opt/ros/indigo/share/genmsg/cmake/genmsg-extras.cmake:307 (include)
  beginner_tutorials/CMakeLists.txt:72 (generate_messages)


-- beginner_tutorials: 0 messages, 0 services
-- +++ processing catkin package: 'my_pcl_tutorial'
-- ==> add_subdirectory(my_pcl_tutorial)
CMake Warning at /opt/ros/indigo/share/catkin/cmake/catkinConfig.cmake:76 (find_package):
  Could not find a package configuration file provided by "pcl_conversions"
  with any of the following names:

    pcl_conversionsConfig.cmake
    pcl_conversions-config.cmake

  Add the installation prefix of "pcl_conversions" to CMAKE_PREFIX_PATH or
  set "pcl_conversions_DIR" to a directory containing one of the above files.
  If "pcl_conversions" provides a separate development package ...
(more)
edit retag flag offensive close merge delete