Ask Your Question
0

Problem while Launching MoveIt! library loading error

asked 2018-12-07 04:52:54 -0500

hpoleselo gravatar image

updated 2018-12-07 04:53:18 -0500

Hello. I'm using ROS Kinetic. For some reason there is a problem loading a library from OpenCV, as shown below:

[ERROR] [1544178952.950336396]: PluginlibFactory: The plugin for class 'moveit_rviz_plugin/MotionPlanning' failed to load.  Error: Failed to load library /opt/ros/kinetic/lib/libmoveit_motion_planning_rviz_plugin.so. Make sure that you are calling the PLUGINLIB_EXPORT_CLASS macro in the library code, and that names are consistent between this macro and your XML. Error string: Could not load library (Poco exception = /opt/ros/kinetic/lib/x86_64-linux-gnu/libopencv_imgproc3.so.3.3: undefined symbol: icv_y8_owns_rFFT_1_scale_32f)

I already tried to reinstall the Moveit! Package, opencv3 for ROS and rebuilding my local workspace but nothing seems to work, still getting the same results.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-12-12 06:23:52 -0500

hpoleselo gravatar image

Managed to fix it by trial and error. I suppose some OpenCV3 .so files from ROS were somehow conflicting with the OpenCV3.4.3 which i installed from source. Eventually what i ended up doing was just uninstall (going to /build folder and $ sudo make uninstall) my sourced/built OpenCV 3.4.3.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2018-12-07 04:52:54 -0500

Seen: 341 times

Last updated: Dec 12 '18