Ask Your Question
0

way-points drift away everytime for amcl navigation

asked 2018-11-13 01:23:29 -0500

updated 2018-11-13 01:28:43 -0500

Running in the simulation with the clearpath husky. I have husky gazebo running at the background. What I intend is to have a set of waypoints and send it as goals through move base.

I tried waypoint_generator at first and declared a set of waypoints around in yaml and when I replayed my map with the yaml the waypoints have already drifted. The yaml looks like series of similar points :

waypoints:
- frame_id: odom
  name: 3.74155664444_0.696490764618
  pose:
    orientation:
      w: 1
      x: 0
      y: 0
      z: 2.4
    position:
      x: 5.0515566444396973
      y: 2.4264907646179199
      z: 0.0

e.g. The originally (1,1,1) position set when replayed has moved to some other location. This is how the drifted waypoints look like.

image description

It could be probably due to the gazebo, for which the world space and coordinates are continuously changing, as a result, the scans don't match too.

Then I also tried using this script that converting amcl pose to 2D Euler and then declares an initial pose and sends a sequence of goals. I configured to my initial pose and a set of 6 points. However as I relaunch the static map, all the points have already moved. As a result, it can never reach its goal and the loop of sending the goal never ends.

Any idea how to stop this drifting of the waypoints and improve the localization.

edit retag flag offensive close merge delete

Comments

does it do the same if you change the frame_id to map in the yaml?

harshal gravatar imageharshal ( 2018-11-13 06:34:19 -0500 )edit

@harshal Hello that solves the problem, thanks a lot. However now at some waypoints, it gets stuck for a while at times trying to get out of the way. Could not quite realize why such a behavior is occurring.

arunavanag gravatar imagearunavanag ( 2018-11-14 01:25:05 -0500 )edit

Gets stuck, as in it can't create a plan(planner) or can't execute the plan(controller)?

If while it is stuck, you can still see the plan by the global planner, try re configuring your local planner params (footprint(global and local), dist from obstacle, inflation,etc)

harshal gravatar imageharshal ( 2018-11-14 04:23:50 -0500 )edit

Thanks @harshal. I guess I have taken care of it in the real robot... anyways just a video of the getting stuck thing, you are probably right about the footprint and inflation. https://drive.google.com/open?id=1tmp...

arunavanag gravatar imagearunavanag ( 2018-11-15 00:41:26 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2018-11-14 01:27:32 -0500

As @harshal suggested the above problem was solved by changing the frame_id to map. waypoints: - frame_id: map name: 3.74155664444_0.696490764618 pose: orientation: w: 1 x: 0 y: 0 z: 2.4 position: x: 5.0515566444396973 y: 2.4264907646179199 z: 0.0

fixed waypoints

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-11-13 01:23:29 -0500

Seen: 61 times

Last updated: Nov 14 '18