Ask Your Question

Segmentation fault while running turtlesim_node

asked 2018-10-22 07:31:52 -0500

erdanielx gravatar image

updated 2018-10-22 08:20:22 -0500

I am following the beginner tutorials for ROS. However, when attempting to run turtlesim by using the command rosrun turtlesim turtlesim_node (after roscorebeing run in a different terminal) I run into a segmentation fault with the following message:

[ INFO] [1540211266.549429837]: Starting turtlesim with node name /turtlesim [ INFO] [1540211266.558342044]: Spawning turtle [turtle1] at x=[5.544445], y=[5.544445], theta=[0.000000] Segmentation fault

I tried uninstalling and installing the turtlesim package, but this didn't work. What can I do about it?

I am using ROS Kinetic on a virtual machine running 64-bit Ubuntu, under Oracle VM Virtualbox.

edit retag flag offensive close merge delete


When reporting SEGFAULTs, always include information about the platform you try to run things on, and how you installed ROS (from sources (ie: compiling yourself) or binary pkgs). If you used any, link to tutorials.

gvdhoorn gravatar image gvdhoorn  ( 2018-10-22 08:03:50 -0500 )edit

I downloaded a .ova file given to me by one of my professors with ROS pre-installed on it, I don't really know what method he used to install it. After doing that I followed the tutorials here, starting from point 1.1.2 (Navigating the ROS Filesystem).

erdanielx gravatar image erdanielx  ( 2018-10-22 08:26:45 -0500 )edit

It is likely then that the ROS pkgs in your VM (always mention the fact that you're using a VM!) and the pkgs you installed to follow the tutorials have gone out-of-sync.

Try upgrading all ROS pkgs inside the VM and see if that helps.

Partial upgrades are not supported by ROS.

gvdhoorn gravatar image gvdhoorn  ( 2018-10-22 10:54:32 -0500 )edit

I decided to install a new VM and install ROS on it myself, I found that better than upgrading all ROS pkgs. Now it works!

erdanielx gravatar image erdanielx  ( 2018-10-23 06:11:54 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2018-10-23 06:13:07 -0500

erdanielx gravatar image

By re-installing ROS on a new VM I was able to solve the problem.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools


Asked: 2018-10-22 07:31:52 -0500

Seen: 240 times

Last updated: Oct 23 '18