Ask Your Question
1

How to upgrade from Orocos KDL 1.3 to 1.4 in ROS Indigo?

asked 2018-10-05 06:43:04 -0600

dpakshimpo gravatar image

updated 2018-10-05 06:43:46 -0600

I need some of the newer APIs present in KDL v1.4.0 in ROS Indigo? I tried to build KDL from source (1.4) and generated the ros-indigo-orocos-kdl library. I replaced this library in the /opt/ros/indigo/lib and when motion planning library is loaded in Rviz, it crashes. Is there any way to use a newer version of KDL library or replace it?

Or, let me know what is the procedure to upgrade to newer library? Or, if it is possible or not?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-12-12 06:13:21 -0600

rhaschke gravatar image

I guess, you are referring to MoveIt as the "motion planning library". If so, you will need to compile MoveIt from source too, as there are some API changes, MoveIt needs to know about as well.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-10-05 06:43:04 -0600

Seen: 65 times

Last updated: Dec 12 '18