Ask Your Question
0

rviz can not send goal to move_base from another computer [closed]

asked 2018-07-29 22:37:08 -0500

AutoCar gravatar image

I am running a car-like robot. I have an move_base node with global/local planner, and I can send goal from rviz to move the car. Now, I want to run the rviz from another computer. Everything works fine, I can see the tf, laser scan etc in rviz. But when I sent the goal with "2D Nav Goal" in rviz from another computer, the car did not move. The car did not get the goal message either when I run "rostopic echo".

Why?

edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by Tom Moore
close date 2018-08-01 05:15:30.601651

Comments

In addition to the suggestions below, make sure the robot can ping your computer by name. If it can't, you need to unset your ROS_HOSTNAME and set your ROS_IP instead.

Tom Moore gravatar imageTom Moore ( 2018-07-30 04:13:32 -0500 )edit

Is this not a duplicate of #q298933?

gvdhoorn gravatar imagegvdhoorn ( 2018-07-30 06:12:45 -0500 )edit

Indeed it is.

Tom Moore gravatar imageTom Moore ( 2018-08-01 05:15:24 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-07-30 03:15:40 -0500

destogl gravatar image

You have to check the following:

  1. Is your ROS_MASTER_URI set properly?
  2. Do you use your world frame as fixed frame (usually "world")?
  3. Can you echo it on local computer?
edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2018-07-29 22:37:08 -0500

Seen: 42 times

Last updated: Jul 30 '18