Ask Your Question
0

Internet connection speed when connected to sensor that has Ethernet interface

asked 2018-07-06 15:49:36 -0500

Kolohe113 gravatar image

updated 2018-07-06 21:51:46 -0500

jayess gravatar image

Hi! I am connecting a LIDAR called UST-20lx to my computer using a Ethernet cable. To do that I have modified /etc/network/ interfaces:

auto lo
iface lo inet loopback

auto enp1s0
iface enp1s0 inet static
address 192.168.0.14
netmask 255.255.255.0
gateway 192.168.0.1
metric 800

I am able to get the LIDAR data using the official urg_node. However, when I was connected to the LIDAR, the internet speed decreased dramatically. For example, I have to wait 30+ second to get into ROS wiki. However, the internet speed seems fine when I go to google and even youtube (no problem watching youtube videos).

Here are my ifconfig:

enp0s31f6 Link encap:Ethernet  HWaddr 00:01:2e:78:1d:00  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:16 Memory:df200000-df220000 

enp1s0    Link encap:Ethernet  HWaddr 00:01:2e:78:1d:01  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:100 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:10692 (10.6 KB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:320 errors:0 dropped:0 overruns:0 frame:0
          TX packets:320 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:27150 (27.1 KB)  TX bytes:27150 (27.1 KB)

wlp3s0    Link encap:Ethernet  HWaddr 3c:f8:62:80:c6:27  
          inet addr:192.168.0.11  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: 2600:8806:3200:d340:90f6:8f12:42e4:9da/64 Scope:Global
          inet6 addr: fe80::cca4:6183:8d81:7c0/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:8985 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4291 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:9437491 (9.4 MB)  TX bytes:985890 (985.8 KB)
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-07-06 20:36:45 -0500

kartikmohta gravatar image

It looks like the wifi and wired interface would have had the same gateway defined which might be causing problems. You can try removing the gateway 192.168.0.1 line on the lidar network interface, you don't need that.

Google and youtube work fine since you're accessing them through IPv6.

edit flag offensive delete link more

Comments

I removed the gateway line and the problem still exist. Can I add a IPv6 line in /etc/network/interfaces to boost the speed?

Kolohe113 gravatar imageKolohe113 ( 2018-07-08 17:45:51 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-07-06 15:47:34 -0500

Seen: 44 times

Last updated: Jul 06 '18