Ask Your Question
0

Gazebo Insufficient GL support

asked 2012-03-01 01:38:38 -0500

TheLegace gravatar image

After many countless hours and testing I finally managed to get gazebo to compile on my Fedora 16 system, no easy task mind you.

Had to install FLTK1.1, assimp locally, manually specific LD_LIBRARY_PATH and VTK_DIR to get all the modules found.

But unfortunately gazebo can't run and it is giving this error:

Part of the Player/Stage Project [http://playerstage.sourceforge.net]. Copyright (C) 2003 Nate Koenig, Andrew Howard, and contributors. Released under the GNU General Public License.

Insufficient GL support [gazebo-2] process has died [pid 3008, exit code -11]. log files: /home/TheLegace/.ros/log/f6ac8c32-63a2-11e1-8777-001fc68ae9ab/gazebo-2*.log
[rosout-1] killing on exit

I am just about ready to pull all my hair out.... I have a nVidia GTX480, should be very well supported. All the GL packages found on the repository I have searched for and installed, the nVidia driver is properly installed and everything should be working. Now I am not sure if it can't find GL because of a linking issue(which I doubt), or because maybe it is running new version of the libraries is not somehow compatible....

I would really like to get gazebo and the whole ros set made into a Fedora repository, I plan on using ROS/Gazebo for a very long time and just recent begin really learning and understanding it. Any help would be appreciated it.

Also could you mention what version of GL libs specifically are used and if they are compatible with the latest versions.

Thank you.

edit retag flag offensive close merge delete

Comments

I am not sure if this will help but, this is the ldd gazebo

TheLegace gravatar image TheLegace  ( 2012-03-01 01:42:06 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2012-03-04 10:18:15 -0500

TheLegace gravatar image

updated 2012-03-22 09:45:31 -0500

Ok, FINALLY I have managed to compile Gazebo and run it properly on a non-Ubuntu system.........

Hallelujah.........one of most difficult things in my life......

The solution to the GL problem was solved using this guide.

http://fedorasolved.org/video-solutions/remove-nvidia-installer

For some reason I am assuming because either there is a bug in nvidia driver or that it just doesn't completely do something required. But I just removed whatever mesa-GL rpms there were on the system and reinstalled the mesa-GL from yum.

I was trying to remove GL related things through yum but that obviously will break everything, but removing them with --no-deps option in rpm and finally IT WORKS.....

EDIT: It looks like installing mesa-GL is a mistake... after removing the gazebo seems to start up again. So the solution is just to remove mesa-GL apparently.

image description

edit flag offensive delete link more

Comments

glad that fixed it. In hind sight, sometimes re-installing the nvidia driver will overwrite the necessary library links and make things work again without having to remove mesa.

hsu gravatar image hsu  ( 2012-03-22 09:58:15 -0500 )edit
0

answered 2012-03-01 01:43:32 -0500

TheLegace gravatar image

Not sure if this will help but linking looks like it's pointing to the right modules.

libzzip-0.so.13 => /usr/lib64/libzzip-0.so.13 (0x00007f830435a000)

        /lib64/ld-linux-x86-64.so.2 (0x000000367ec00000)
        libfltk_gl.so.1.1 => /usr/local/lib/libfltk_gl.so.1.1 (0x00007f830413e000)
        libGLU.so.1 => /usr/lib64/libGLU.so.1 (0x000000368c800000)
        libGL.so.1 => /usr/lib64/libGL.so.1 (0x00007f8303ec0000)
        libfltk.so.1.1 => /usr/local/lib/libfltk.so.1.1 (0x00007f8303c28000)
        libfltk_images.so.1.1 => /usr/local/lib/libfltk_images.so.1.1 (0x00007f8303a1d000)
        libfltk_forms.so.1.1 => /usr/local/lib/libfltk_forms.so.1.1 (0x00007f8303816000)
        libXpm.so.4 => /usr/lib64/libXpm.so.4 (0x000000368e200000)
        libgomp.so.1 => /usr/lib64/libgomp.so.1 (0x0000003689800000)
edit flag offensive delete link more

Comments

What's the output of 'ls -l /usr/lib64/libGL.so.1'? Is this really the nvidia driver's libGL.so? I recently ran into a problem with another program where mesa's libGL.so was used although I had nvidia installed.

Lorenz gravatar image Lorenz  ( 2012-03-01 05:03:06 -0500 )edit

lrwxrwxrwx. 1 root root 12 Feb 21 16:54 /usr/lib64/libGL.so.1 -> libGL.so.1.2

TheLegace gravatar image TheLegace  ( 2012-03-03 12:49:57 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-03-01 01:38:38 -0500

Seen: 1,633 times

Last updated: Mar 22 '12