Ask Your Question
0

ros-kinetic-navigation installation problem

asked 2018-04-10 13:59:47 -0600

mewbot gravatar image

updated 2018-04-10 14:10:47 -0600

gvdhoorn gravatar image

Im trying to install the ros navigation stack using apt-get install ros-kinetic-navigation but it shows this error :

$ sudo apt-get install ros-kinetic-navigation
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ros-kinetic-navigation : Depends: ros-kinetic-map-server but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I tried building from source and i still get error like this :

-- +++ processing catkin metapackage: 'navigation'
-- ==> add_subdirectory(navigation)
-- +++ processing catkin package: 'map_server'
-- ==> add_subdirectory(map_server)
-- Using these message generators: gencpp;geneus;genlisp;gennodejs;genpy
CMake Error at /usr/share/cmake-3.5/Modules/FindPackageHandleStandardArgs.cmake:148 (message):
  Could NOT find Bullet (missing: BULLET_DYNAMICS_LIBRARY
  BULLET_COLLISION_LIBRARY BULLET_MATH_LIBRARY BULLET_SOFTBODY_LIBRARY
  BULLET_INCLUDE_DIR)
Call Stack (most recent call first):
  /usr/share/cmake-3.5/Modules/FindPackageHandleStandardArgs.cmake:388 (_FPHSA_FAILURE_MESSAGE)
  /usr/share/cmake-3.5/Modules/FindBullet.cmake:95 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
  map_server/CMakeLists.txt:11 (find_package)


-- Configuring incomplete, errors occurred!
See also "/home/mew/catkin_ws/build/CMakeFiles/CMakeOutput.log".
See also "/home/mew/catkin_ws/build/CMakeFiles/CMakeError.log".
Makefile:2068: recipe for target 'cmake_check_build_system' failed
make: *** [cmake_check_build_system] Error 1
Invoking "make cmake_check_build_system" failed

is there any fix for this?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2018-04-10 22:49:24 -0600

mewbot gravatar image

updated 2018-04-11 01:47:31 -0600

jayess gravatar image

It needs an old version of libpulse0 try running

sudo apt-get install libpulse0=1:8.0-0ubuntu3
edit flag offensive delete link more

Comments

it is working

mewbot gravatar imagemewbot ( 2018-04-10 22:51:02 -0600 )edit
0

answered 2018-09-04 02:58:08 -0600

SA gravatar image

Hello Jayess,

I am getting a similar error with an installation of map-server. Could this also be because of dependency on an older 16.0.4 library?

The following packages have unmet dependencies. ros-kinetic-map-server : Depends: libsdl-image1.2-dev but it is not going to be installed Depends: libsdl1.2-dev but it is not going to be installed E: Unable to correct problems, you have held broken packages.

Full details of the issue and resolution steps tried so far are here - http://en.robotis.com/service/forum_v... - and here - https://answers.ros.org/question/3022...

Any help would be much appreciated.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-04-10 13:59:47 -0600

Seen: 1,488 times

Last updated: Sep 04 '18