"Dropped 100.00% of messages so far." warning when starting gmapping

asked 2018-02-27 11:31:11 -0500

nora gravatar image

updated 2018-02-27 12:13:28 -0500

jayess gravatar image

Hi! I am a new user to ros and I am trying to build a 2D map. the map I am trying to build it without using rosbag. However, when starting the gmapping I get this warning message:

[ WARN] [1519751956.023092942, 62.752000000]: MessageFilter [target=robot/odom ]: Dropped 100.00% of messages so far. Please turn the [ros.gmapping.message_notifier] rosconsole logger to DEBUG for more information.

the steps I followed was:

  1. start the ros master
  2. launch the robot in the environment
  3. start the gmapping ( the warning here! ) $rosrun gmapping slam_gmapping
  4. move the robot around then close it
  5. start the map server and it keep tilling me to wait with nothing happening I think that whatever caused the warning is whats wrong but I cant figure it out??
edit retag flag offensive close merge delete

Comments

1

Did you consider doing what the message tells you? (setting the loglevel to debug)

Humpelstilzchen gravatar imageHumpelstilzchen ( 2018-02-28 05:32:59 -0500 )edit

I don't know how to do that.

nora gravatar imagenora ( 2018-02-28 05:35:45 -0500 )edit
2

Open rqt_logger_level select the mentioned logger and set it to debug.

Humpelstilzchen gravatar imageHumpelstilzchen ( 2018-02-28 07:13:36 -0500 )edit