Ask Your Question
0

Navigation Stack and Odometry issue

asked 2018-08-29 10:05:00 -0600

lorenznew gravatar image

updated 2018-08-29 10:06:22 -0600

Hello everyone,

I try to get the navigation Stack with gmapping running on my robot. The odometry and Gmapping are very good as long as I move the robot with my keyboard.

As soon as I give the first navigation goal, the robot starts moving, but the position in the map is not updated until move_base stops its navigation. Btw. the robot does not reach its goal, but the direction is right. So it seems like the controlling by the navigation stack does block the new odometry information.

I think that could happen because the serial connection to my hardware-control-board (which is controlling sensors+motors) cant handle the odometry and the navigation communication togther. Important to say is, that odometry and keyboard control are working fine together

So my question is: Is there a way to recuce the frequency of the cmd_vel msgs published by the navigation stack?

or does anyone have an other idea what could be wrong?!

thanks so much Lorenz

edit retag flag offensive close merge delete

Comments

cmd_vel is already a low bandwidth message. It's a short message not issued very often. I suggest you add additional info to the post. Include your RQT Graph and TF frames. Capture while NAV stack is running. it will help see if you have correct messages between nodes. Post yaml and launch files.

billy gravatar imagebilly ( 2018-08-29 11:39:20 -0600 )edit

hey, thanks a lot for your help, I will add them as soon as I can. But I think the ROS-communication is working. The Serial connection to the hardwarecontroller could be the Prolem. thanks a lot for your help

lorenznew gravatar imagelorenznew ( 2018-08-30 07:22:55 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2018-08-29 13:19:09 -0600

If you're using your keyboard, that just means the command velocity topic is working, not that you're getting odometry. If you're not getting odometry back, you're right the robot would not be able to update its position since no new information is coming through.

You can reduce the cmd_vel frequency from your local planner my changing the frequency it runs in the navigation parameters if you believe its a bandwidth issue.

edit flag offensive delete link more

Comments

When I control the Robot with the keyboard the odometry is correctly displayed in rviz. it is very sooth and I have a quiet low drift. can you tell which Parameter in which file i have to change? thanks!

lorenznew gravatar imagelorenznew ( 2018-08-30 07:26:50 -0600 )edit
1

I would recommend just reading the documentation, it should be pretty clear from that.

http://wiki.ros.org/move_base#Parameters

stevemacenski gravatar imagestevemacenski ( 2018-08-30 12:49:26 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2018-08-29 10:05:00 -0600

Seen: 192 times

Last updated: Aug 29 '18