Ask Your Question
0

Problem in wiimote_node.py

asked 2012-02-21 05:31:37 -0500

anonymous user

Anonymous

Hello,

i have a problem when i start the wiimote_node with rosrun wiimote wiimote_node.py. I get the following error message:

Traceback (most recent call last): File "wiimote_node.py", line 100, in <module> import wiimote.WIIMote File "/opt/ros/electric/stacks/joystick_drivers/wiimote/src/wiimote/WIIMote.py", line 48, in <module> import cwiid ImportError: /opt/ros/electric/stacks/joystick_drivers/cwiid/cwiid/lib/libcwiid.so.1: undefined symbol: clock_gettime

has anyone encountered the problem yet? I'm running out of ideas.

My os is ubuntu 11.10 32-bit

edit retag flag offensive close merge delete

Comments

can you include what version of joystick drivers you have installed (look at the CMakeLists.txt in joystick_drivers).. I just installed the latest from the package manager (1.6.4) and ran it and it worked.

mmwise gravatar image mmwise  ( 2012-03-16 13:25:04 -0500 )edit

1 Answer

Sort by » oldest newest most voted
2

answered 2012-03-16 01:38:37 -0500

claeslund gravatar image

Yes I have had the same problem.

It is the libcwiid that comes with ROS Electric that is the problem. You can solve it be doing the following:

install libcwiid1 and libcwiid-dev with synaptic or apt.

go to

/opt/ros/electric/stacks/joystick_drivers/cwiid/cwiid/lib/

remove or rename

libcwiid.so libcwiid.so.1 libcwiid.so.1.0

Create the following symbolic links with “sudo ln -s”

libcwiid.so -> /usr/lib/libcwiid.so libcwiid.so.1 -> /usr/lib/libcwiid.so.1 libcwiid.so.1.0 -> /usr/lib/libcwiid.so.1.0

example: sudo ln -s libcwiid.so /usr/lib/libcwiid.so

This will solve your problem.

edit flag offensive delete link more

Comments

Had same issue while using wiimote in ROS Electric. The provided solution solved the problem. Also the symbolic link command should be "sudo ln -s /usr/lib/libcwiid.so libcwiid.so"

piyushk gravatar image piyushk  ( 2012-05-21 10:04:27 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-02-21 05:31:37 -0500

Seen: 357 times

Last updated: Mar 16 '12