Ask Your Question
3

costmap2D from 3Dpointcloud

asked 2012-02-14 05:25:46 -0500

prince gravatar image

updated 2014-01-28 17:11:22 -0500

ngrennan gravatar image

I am trying to follow tutorial http://www.ros.org/wiki/navigation/Tutorials/RobotSetup. After setting various prerequisites for launch, with move_base launch file, move_base node results in 2D costmap, obstacles, inflated obstacles etc. In rviz visualization, it is observed that obstacles detected are not getting cleared in subsequent published costmaps. Old obstacles becomes part of current costmap as well. Suddenly after sometime, everything is cleared and a correct cost map is displayed. Am I missing setting up any specific parameter? Current all parameters are as advised in tutorial. I had set "observation_persistence: 0.0" in costmap_common_params.yaml but it do not help.

Following is a set of screenshots of rviz

Screen 1:Unlimited Free Image and File Hosting at MediaFire

Screeshot 2: Unlimited Free Image and File Hosting at MediaFire

Screeshot 3: Unlimited Free Image and File Hosting at MediaFire

Screeshot 4:Unlimited Free Image and File Hosting at MediaFire

Screenshot5: Unlimited Free Image and File Hosting at MediaFire This is taken after around 12 seconds from screenshot4. Semicircles in front and back of robot are artifacts of costmap. It is plain road.

This is published on topic /move_base/local_costmap/obstacles.

edit retag flag offensive close merge delete

Comments

This is when driving by an obstacle?

DimitriProsser gravatar image DimitriProsser  ( 2012-02-14 06:17:21 -0500 )edit

We had captured one data set as bag which I am replaying for test purposes. The accumulations of previous obstacles in latest costmap is happening continuously. For example when taking a turn in. In this case, obstacles which were on left will shift in horizon and also previous position will stay.

prince gravatar image prince  ( 2012-02-14 17:00:20 -0500 )edit

I had edited original question to add screenshots to it.

prince gravatar image prince  ( 2012-02-14 17:58:47 -0500 )edit

3 Answers

Sort by » oldest newest most voted
2

answered 2012-03-02 09:28:02 -0500

tfoote gravatar image

The tuning suggestions in that tutorial are designed for indoor robots. Once you take it outdoors you will need to make the costmap much more permissive for not flat roads and miscalibrations in your data.

FYI: Having worked on autonomous vehicles roads are not flat at all.

edit flag offensive delete link more
1

answered 2012-02-16 23:52:41 -0500

I'd similar problems visualizing point clouds in a specific computer. The problem was the same as your, the point cloud was not cleared from rviz event if there were no data, at the end the problem was the graphic card of that computer, because I checked the algorithm on other machines and it worked perfecly. It seems stupid, but have you tried on other PCs?

edit flag offensive delete link more

Comments

We had tried on different machines, although not thinking about this possibility. I believe obstacles are not getting cleared properly. Also My frame moves with the robot. I want it this way. This is input to local planner.

prince gravatar image prince  ( 2012-02-21 16:07:24 -0500 )edit

I suppose that you're well defining the observation sources (at costmap_common_params.yaml), with the clearing parameter set to "true", right? (it's something obious but we must be sure...;P)

Àngel - IRI gravatar image Àngel - IRI  ( 2012-02-21 21:37:40 -0500 )edit

Yes, it is set to true. Screenshot 5 even confirms this. After playing data for around 15secs, costmap gets cleared.

prince gravatar image prince  ( 2012-02-22 18:21:15 -0500 )edit
1

And also and obvious parameter that it must be checked, the Decay Time in rviz, is set to 0, right?

Àngel - IRI gravatar image Àngel - IRI  ( 2012-02-22 21:32:13 -0500 )edit

Yes it is.

prince gravatar image prince  ( 2012-02-22 22:46:25 -0500 )edit
0

answered 2012-05-09 08:28:58 -0500

PeterW gravatar image

I know this is old topic but I have same problem. I'am working indoor. Map gets almost cleared but a few single points stays and global planner is unable to plan path. Did you solve it?

edit flag offensive delete link more

Comments

not completely. I followed Tfoote suggestions. Some points representing false obstacles still appears!

prince gravatar image prince  ( 2012-05-09 20:05:31 -0500 )edit

Ok, but I have your problem with indoor navigation in quasi-static case (robot drives few meters across corridor and stops on small fake obstacle e.g. after somebody crosses its way)

PeterW gravatar image PeterW  ( 2012-05-14 23:17:18 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-02-14 05:25:46 -0500

Seen: 938 times

Last updated: May 09 '12