Ask Your Question
0

razor_imu_9dof can not install with SparkFun 9DoF Razor IMU M0

asked 2017-10-20 23:31:03 -0500

play4fun gravatar image

updated 2017-10-21 02:01:49 -0500

ahendrix gravatar image

I just buy SparkFun 9DoF Razor IMU M0, https://www.sparkfun.com/products/14001 , want to install http://wiki.ros.org/razor_imu_9dof,but failed

problem is :in razor_imu_9dof tutorial,it's using old IMU , SparkFun 9DoF Razor IMU (SEN-10736) - Initial release, featuring an ATmega328, ADXL345 (accelerometer), ITG-3200 (gyroscope), and HMC5883L (magnetometer).

I buy the new one :SparkFun 9DoF Razor IMU M0 (SEN-14001)

what should I do in http://wiki.ros.org/razor_imu_9dof#Lo... ?

Firmware can not upload to IMU M0 .

Razor_AHRS.ino:

// HARDWARE OPTIONS

/*********************/

// Select your hardware here by uncommenting one line!

//#define HW__VERSION_CODE 10125 // SparkFun "9DOF Razor IMU" version "SEN-10125" (HMC5843 magnetometer)

//#define HW__VERSION_CODE 10736 // SparkFun "9DOF Razor IMU" version "SEN-10736" (HMC5883L magnetometer)

//#define HW__VERSION_CODE 10183 // SparkFun "9DOF Sensor Stick" version "SEN-10183" (HMC5843 magnetometer)

//#define HW__VERSION_CODE 10321 // SparkFun "9DOF Sensor Stick" version "SEN-10321" (HMC5843 magnetometer)

//#define HW__VERSION_CODE 10724 // SparkFun "9DOF Sensor Stick" version "SEN-10724" (HMC5883L magnetometer)

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
1

answered 2017-11-29 05:09:47 -0500

Hi There, I'm currently working through the same problem, trying to get the razor_imu_9dof ROS node to work with the new 14001 based sparkfun boards. I'm (hopefully) almost there, I've found the git repo below that does work with the new board. It outputs the linear and angular accelerations fine although as far as I can tell the orientation estimate is wrong, I'm getting incorrect values or NANs.

https://github.com/lebarsfa/razor-9dof-ahrs

Depending on your application this may solve your problem straight away, if you only need the acceleration values.

edit flag offensive delete link more
1

answered 2017-10-21 02:05:07 -0500

ahendrix gravatar image

updated 2017-10-21 02:05:17 -0500

According to this issue on the bug tracker for razor_imu_9dof, it looks like razor_imu_9dof doesn't support the newer boards, but it looks like there's another package or firmware that might.

edit flag offensive delete link more

Comments

Thanks,I have already try it ,still not working. don't know why.

play4fun gravatar imageplay4fun ( 2017-10-22 20:52:58 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2017-10-20 23:22:06 -0500

Seen: 849 times

Last updated: Nov 29 '17