Ask Your Question
0

overshoot pose from robot_localization

asked 2017-10-09 22:23:24 -0500

fj138696 gravatar image

Hi everyone!

I'd like to seek your support in running robot_localization. here is my current configuration.

ODOM Source: iRobotcreate2 using autonomy_create driver publishing odom->base_link at 50Hz, frame_id = odom child_frame_id = base_link

IMU Source: LPMS USBAL2 using lpms_imu from larics publishing /imu_data topic at 50Hz, frame_id = base_link

  <node name="robot_localization" pkg="robot_localization" type="ekf_localization_node" clear_params="true" output="screen" >

robot_localization launch

  <param name="frequency" value="50"/>

  <param name="sensor_timeout" value="0.1"/>

  <param name="odom0" value="/odom"/>
  <param name="imu0" value="/imu_data"/>

  <param name="odom_frame" value="odom"/>
  <param name="base_link_frame" value="base_link"/>
  <param name="world_frame" value="odom"/>
  <param name="two_d_mod" value="true"/>
  <param name="publish_tf" value="false"/>

  <rosparam param="odom0_config">[false, false, false,
                                  false, false, false,
                                  true, true, false,
                                  false, false, false,
                                  false, false, false]</rosparam>

  <rosparam param="imu0_config">[false, false, false,
                                 false, false, true,
                                 false, false, false,
                                 false, false, false,
                                 false, false, false]</rosparam>

  <param name="odom0_queue_size" value="10"/>
  <param name="imu0_queue_size" value="10"/>

  <param name="imu0_remove_gravitational_acceleration" value="false"/>
  <param name="odom0_differential" value="false"/>
  <param name="imu0_differential" value="false"/>

  <rosparam param="process_noise_covariance">[0.03, 0,    0,   0,    0,    0,    0,     0,     0,    0,     0,     0,     0,    0,    0,
                                              0,    0.03, 0,   0,    0,    0,    0,     0,     0,    0,     0,     0,     0,    0,    0,
                                              0,    0,    0.4, 0,    0,    0,    0,     0,     0,    0,     0,     0,     0,    0,    0,
                                              0,    0,    0,   0.03, 0,    0,    0,     0,     0,    0,     0,     0,     0,    0,    0,
                                              0,    0,    0,   0,    0.03, 0,    0,     0,     0,    0,     0,     0,     0,    0,    0,
                                              0,    0,    0,   0,    0,    0.06, 0,     0,     0,    0,     0,     0,     0,    0,    0,
                                              0,    0,    0,   0,    0,    0,    0.025, 0,     0,    0,     0,     0,     0,    0,    0,
                                              0,    0,    0,   0,    0,    0,    0,     0.025, 0,    0,     0,     0,     0,    0,    0,
                                              0,    0,    0,   0,    0,    0,    0,     0,     0.05, 0,     0,     0,     0,    0,    0,
                                              0,    0,    0,   0,    0,    0,    0,     0,     0,    0.002, 0,     0,     0,    0,    0,
                                              0,    0,    0,   0,    0,    0,    0,     0,     0,    0,     0.002, 0,     0,    0,    0,
                                              0,    0,    0,   0,    0,    0,    0,     0,     0,    0,     0,     0.004, 0,    0,    0,
                                              0,    0,    0,   0,    0,    0,    0,     0,     0,    0,     0,     0,     0.01, 0,    0,
                                              0,    0,    0,   0,    0,    0,    0,     0,     0,    0,     0,     0,     0,    0.01, 0,
                                              0,    0,    0,   0,    0,    0,    0,     0,     0,    0,     0,     0,     0,    0,    0.01]</rosparam>

  <rosparam param="initial_estimate_covariance">[1e-9, 0,    0,    0,    0,    0,    0,    0,    0,    0,     0,     0,     0,    0,    0,
                                                 0,    1e-9, 0,    0,    0,    0,    0,    0,    0,    0,     0,     0,     0,    0,    0,
                                                 0,    0,    1e-9, 0,    0,    0,    0,    0,    0,    0,     0,     0,     0,    0,    0,
                                                 0,    0,    0,    1e-9, 0,    0,    0,    0,    0,    0,     0,     0,     0,    0,    0,
                                                 0,    0,    0,    0,    1e-9, 0,    0,    0,    0,    0,     0,     0,     0,    0,    0,
                                                 0,    0,    0,    0,    0,    1e-9, 0,    0,    0 ...
(more)
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-01-10 11:25:55 -0500

Tom Moore gravatar image

The pose is moving rapidly because your X velocity data is extremely large. This is from your odom data, presumably from autonomy_create.

header: 
  seq: 934
  stamp: 
    secs: 1507602481
    nsecs:  80840055
  frame_id: "odom"
child_frame_id: "base_link"
pose: 
  pose: 
    position: 
      x: 0.0602380000055
      y: 0.00023190813954
      z: 0.0
    orientation: 
      x: 0.0
      y: 0.0
      z: 0.000945881799379
      w: 0.999999552654
  covariance: [0.03145275264978409, 7.371223910013214e-05, 0.0, 0.0, 0.0, -0.003105021081864834, 7.371225365204737e-05, 0.002794417552649975, 0.0, 0.0, 0.0, 0.06957972049713135, 0.0, 0.0, 1.7976931348623157e+308, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 1.7976931348623157e+308, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 1.7976931348623157e+308, 0.0, -0.0031050220131874084, 0.06957972049713135, 0.0, 0.0, 0.0, 2.2781670093536377]
twist: 
  twist: 
    linear: 
      x: 4.96720266342
      y: 0.0
      z: 0.0
    angular: 
      x: 0.0
      y: 0.0
      z: 0.0
  covariance: [0.00044456301839090884, 8.409973020206962e-07, 0.0, 0.0, 0.0, -2.7008354663848877e-08, 8.409971883338585e-07, 7.954953140654197e-09, 0.0, 0.0, 0.0, 1.4315063708636444e-05, 0.0, 0.0, 1.7976931348623157e+308, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 1.7976931348623157e+308, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 1.7976931348623157e+308, 0.0, -2.7124769985675812e-08, 1.4315063708636444e-05, 0.0, 0.0, 0.0, 0.03220024332404137]

Look at twist/twist/linear/x. See how it's approximately 5? The units are meters per second for velocities, so the EKF thinks your robot is going at 5 m/s. I'd check the source code for the autonomy_create package, if that's what's generating this message.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2017-10-09 22:23:24 -0500

Seen: 122 times

Last updated: Jan 10 '18