Ask Your Question
0

There is no lidar image after launched the sensor [closed]

asked 2017-09-25 04:02:19 -0500

gambit gravatar image

updated 2017-09-26 03:49:35 -0500

gvdhoorn gravatar image

I have install and launched r2000 lidar. Rviz appeared but there is no scan image.


Edit:

ROS_MASTER_URI=http://localhost:11311
core service [/rosout] found
process[r2000_driver_node-1]: started with pid [4952]
process[dummy_slam_broadcaster-2]: started with pid [4953]
process[rvizLocal-3]: started with pid [4961]
Connecting to scanner at 192.168.1.203 ... Exception: Connection refused
ERROR: Exception: <unspecified file>(1): expected object or array
ERROR: Could not connect to laser range finder!
FAILED!
Connection to scanner at 192.168.1.203 failed!
_IceTransSocketUNIXConnect: Cannot connect to non-local host 8051
_IceTransSocketUNIXConnect: Cannot connect to non-local host 8051
Qt: Session management error: Could not open network socket
[ INFO] [1506500846.847457559]: rviz version 1.11.18
[ INFO] [1506500846.847563031]: compiled against Qt version 4.8.6
[ INFO] [1506500846.847608486]: compiled against OGRE version 1.8.1 (Byatis)
[ INFO] [1506500847.409381557]: Stereo is NOT SUPPORTED
[ INFO] [1506500847.409596281]: OpenGl version: 3 (GLSL 1.3).

I have still having problem after changing the host address.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by gambit
close date 2017-10-02 20:09:05.180400

Comments

Please see our support guidelines and update your question.

As it is we cannot help you effectively.

gvdhoorn gravatar image gvdhoorn  ( 2017-09-25 04:42:20 -0500 )edit

Please do not post answers unless you are answering your own question. For updates, edit your original question. For everything else (ie: interacting with other posters), use comments.

I've merged your answer with your original question. Please use the edit button/link in the future.

Thanks.

gvdhoorn gravatar image gvdhoorn  ( 2017-09-25 05:14:56 -0500 )edit

I have no experience with this particular device or ROS node, but from the error message I would say you have not succeeded in "installing" the r2000 lidar. Please check your configuration and physical setup and fix that. Have you correctly configured the ROS pkg/node?

gvdhoorn gravatar image gvdhoorn  ( 2017-09-25 05:16:59 -0500 )edit

I have followed the steps from the answer in other post about installing new pkg.

gambit gravatar image gambit  ( 2017-09-25 19:39:28 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-09-26 08:04:15 -0500

kmhallen gravatar image

This looks like a networking issue. Can you ping the scanner's IP address?

Make sure the IP address in ROS matches the IP address of the scanner. You can change the network settings on the scanner with the two buttons.

Make sure your Linux networking settings are correct for the scanner's IP range.

edit flag offensive delete link more

Comments

I knew the IP address for lidar and it has worked perfectly with another pc. The problem occurred when I work with a new pc.

gambit gravatar image gambit  ( 2017-09-26 19:51:28 -0500 )edit

I have also encounter roscore error whenever I start.

A common cause is that the machine cannot ping itself. Please check for errors by running:

ping soosoo

gambit gravatar image gambit  ( 2017-09-26 19:52:09 -0500 )edit

I have solved the roscore error by re-install ubuntu and change the hostname. Thank you

gambit gravatar image gambit  ( 2017-09-27 02:34:16 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2017-09-25 04:02:19 -0500

Seen: 233 times

Last updated: Sep 26 '17