Ask Your Question
0

Unable to locate package camera_calibration

asked 2017-09-12 09:47:53 -0600

Sulphur gravatar image

When I do

rosdep install camera_calibration

I get the following error:

ERROR: Rosdep cannot find all required resources to answer your query

Missing resource camera_calibration

ROS path [0]=/opt/ros/kinetic/share/ros

ROS path 1]=/home/tintin/catkin_ws/src

ROS path [2]=/opt/ros/kinetic/share

A similar question was posted here but there isn't a complete solution yet. I tried the solution given there too.

  1. For

sudo apt-get install camera_calibration

I am getting "Unable to locate package camera_calibration"

  1. For

sudo apt-get install ros-fuerte-image-pipeline

I am getting "Unable to locate package ros-fuerte-image-pipeline"

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
1

answered 2017-09-12 11:32:44 -0600

jayess gravatar image

updated 2020-06-26 14:45:31 -0600

From the errors that you posted it looks like you're using Kinetic. I'm not sure about the error that you're getting with rosdep, but the reason that you can't install image_pipeline (which contains the camera_calibration package) is because you're trying to install the version for Fuerte. Try

sudo apt-get install ros-kinetic-image-pipeline

You can install many packages using the following command format

sudo apt-get install ros-<distribution>-<package-name>

where <distribution> is the distribution that you're using and <package-name> is the package that you're trying to install.

edit flag offensive delete link more

Comments

I tried the same command sudo apt-get install ros-kinetic-image-pipelline but with my distribution name which is ros melodic but it have the same error cannot find package what could be the problem then?

bansi_lol gravatar image bansi_lol  ( 2020-06-26 05:49:23 -0600 )edit

Sorry my mistake I copied and pasted the command and didnt notice there is a spelling mistake **pipeline

bansi_lol gravatar image bansi_lol  ( 2020-06-26 06:10:38 -0600 )edit

Thanks for catching the mistake. I've updated the answer.

jayess gravatar image jayess  ( 2020-06-26 14:45:53 -0600 )edit
0

answered 2018-12-17 17:02:28 -0600

saikat gravatar image

this is a step by step very good tutorial, (youtube link) link text ,this helped me a lot in my project, you can refer this one,hope it will help

edit flag offensive delete link more

Comments

Please don't post link-only answers. If the video disappears (which happens often) then this answer will not have much value.

jayess gravatar image jayess  ( 2019-01-16 23:51:05 -0600 )edit
0

answered 2018-12-14 12:07:33 -0600

Ilhamasy gravatar image

absolutely, you install raspbian based on ROS isn't it? in fact, camera_calibration and image_pipeline has already install with them

edit flag offensive delete link more

Comments

so, just run it for calibration : $ rosrun usb_cam usb_node $ rosrun camera_calibration cameracalibrator.py --size 9x6 --square 0.02517 image:=/usb_cam/image_raw camera:=/usb_cam --no-service-check

fyi: before run this you just download git clone the package image_pipeline and then catkin_make

Ilhamasy gravatar image Ilhamasy  ( 2018-12-14 13:26:21 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-09-12 09:47:53 -0600

Seen: 2,406 times

Last updated: Jun 26 '20