ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Waiting for the move_base action server to come up

asked 2021-08-20 05:43:57 -0600

troyelex gravatar image

updated 2021-08-20 06:01:24 -0600

Hi, I'm facing this issue, getting "Waiting for the move_base action server to come up". I am running all nodes on same laptop.

gazebo + jackal_sim_robot + jackal_sim_mec + jackal_lnav (this contain amcl and move_base) + simple_navigation_goal node. simple navigation goal node is used from link:

I am able to navigate robot in rviz but when i run simple_navigation_goal node , it print log "Waiting for the move_base action server to come up". ! Please help.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted

answered 2021-08-21 20:13:26 -0600

Mike Scheutzow gravatar image

This error usually means that move_base is not running, or that the simple_navigation_goal is not configured with the correct action server name for the move_base node. Do a rostopic list and look for a move_base topic ending in /goal. The entire path preceding the /goal portion is the name of the action server.

edit flag offensive delete link more


Thanks for answering. after using "jackal/move_base" in client code i am able to send goal to mobe_base server.

troyelex gravatar image troyelex  ( 2021-08-23 00:18:09 -0600 )edit

Hey, mine is /move_base/goal and /move_base_simple/goal, but it is still showing the same error. Can you help?

RRK gravatar image RRK  ( 2022-02-01 11:43:35 -0600 )edit

move_base_simple is not an ActionServer, the move_base developers just chose a similar name. An ActionServer will create 3 topics: goal, feedback and result. In your case, the ActionServer name is probably "/move_base" (but look for those other topic names to be sure.)

Mike Scheutzow gravatar image Mike Scheutzow  ( 2022-02-13 12:17:14 -0600 )edit

@Mike Scheutzow I'm having the same issue where I have the the server name correct(move_base), but nothing happens. I'm trying to use the action client and server move the robot around while it's getting map information from SLAM. Please take a look at my question here

distro gravatar image distro  ( 2022-07-23 20:10:11 -0600 )edit

Question Tools

1 follower


Asked: 2021-08-20 05:43:57 -0600

Seen: 1,422 times

Last updated: Aug 21 '21