Ask Your Question
0

Unable to install fetch (sudo apt-get install ros-indigo-fetch*)

asked 2017-09-09 18:16:17 -0600

roy gravatar image

updated 2017-09-10 02:11:58 -0600

gvdhoorn gravatar image

Guys,

I am trying to install the Fetch model on my machine but failed to do so due to following error:

roy@RoysMacUbuntu:~/ws/src/stockroom_bot$ sudo apt-get install ros-indigo-fetch*
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package ros-indigo-fetch*
E: Couldn't find any package by glob 'ros-indigo-fetch*'

I also tried ros-kinetic-fetch* (because I am using ROS kinetic). Didn't work either:

roy@RoysMacUbuntu:~/ws/src/stockroom_bot$ sudo apt-get install ros-kinetic-fetch*
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package ros-kinetic-fetch*
E: Couldn't find any package by glob 'ros-kinetic-fetch*'
E: Couldn't find any package by regex 'ros-kinetic-fetch*'

I ran apt-get update already.

Any idea where the problem might be?

Many thanks for your time.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
2

answered 2017-09-10 02:11:36 -0600

gvdhoorn gravatar image

updated 2017-09-10 02:16:38 -0600

tl;dr: as of 2017-09-10 there is no (official) binary release of the Fetch Robotics packages for Ubuntu Xenial-ROS Kinetic, so the commands you show are expected to fail


I am using ROS kinetic

and

roy@RoysMacUbuntu:~/ws/src/stockroom_bot$ sudo apt-get install ros-indigo-fetch*
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package ros-indigo-fetch*
E: Couldn't find any package by glob 'ros-indigo-fetch*'

This will never work as Indigo binaries (.debs) are not available on OS where you can install Kinetic. I guess you are running Ubuntu Xenial, for which only ROS Kinetic has been released.

roy@RoysMacUbuntu:~/ws/src/stockroom_bot$ sudo apt-get install ros-kinetic-fetch*
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package ros-kinetic-fetch*
E: Couldn't find any package by glob 'ros-kinetic-fetch'
E: Couldn't find any package by regex 'ros-kinetic-fetch'

I ran apt-get update already.

Any idea where the problem might be?

And this can't work as the Fetch packages have not been released into Kinetic. See status_page/ros_kinetic_default.html?q=fetch (indigo status for comparison) and the wiki/fetch_maps page (fi, this is just an example).

According to fetchrobotics/fetch_ros#56, it should be possible to build the various packages from sources in a Catkin workspace on a Xenial-Kinetic install, but as always, you might encounter some issues.

Note that just git clone-ing the repositories into a Catkin workspace is not enough. See #q252478 for the general steps needed to build packages from source.

edit flag offensive delete link more
0

answered 2019-08-14 01:52:16 -0600

Sorry to respond to an old issue.

@gvdhoorn answered very well.

Fetch skipped Lunar and Kinetic... However we're currently supporting Melodic.

Unofficially, some packages may now be available in Kinetic but I'm not actively maintaining or testing on Kinetic, and the drivers were not released into Kinetic.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-09-09 18:16:17 -0600

Seen: 735 times

Last updated: Aug 14