Moveit in nanopi M3 board not working.

asked 2017-08-14 09:27:09 -0600

Gokul gravatar image

updated 2017-08-14 10:09:10 -0600

I have installed ubuntu 16.04(32-bit) provided by the official site of friendly arm on Nanopi m3 controller board which uses Samsung S5P6818 Octa-Core Cortex-A53, 400M Hz - 1.4G Hz and has 1 Gb RAM. And have installed ROS kinetic distro on it. I have also installed moveit in debian and then when I launch moveit setup assistant and load the URDF, it crashes with this error message.


       REQUIRED process [moveit_setup_assistant-1] has died!
  process has died [pid 31548, exit code -11, cmd /opt/ros/kinetic/lib/moveit_setup_assistant/moveit_setup_assistant          __name:=moveit_setup_assistant __log:=/root/.ros/log/aae05fe4-80df-11e7-902d-94a1a29301e8/moveit_setup_assistant-  1.log].   log file: /root/.ros/log/aae05fe4-80df-11e7-902d-94a1a29301e8/moveit_setup_assistant-1*.log Initiating shutdown!

So, I created the moveit config file in another system and tried launching move_group.launch. It also crashes with the error message.

  [move_group-1] process has died [pid 30902, exit code -11, cmd /opt/ros/kinetic/lib/moveit_ros_move_group/move_group __name:=move_group __log:=/root/.ros/log/aae05fe4-80df-11e7-902d-94a1a29301e8/move_group-1.log].log file: /root/.ros/log/aae05fe4-80df-11e7-902d-94a1a29301e8/move_group-1*.log

I tried inspecting the log files but there was no log files created.

How to fix this error. Could someone kindly shed light on this.

Thanks in advance.

edit retag flag offensive close merge delete