Ask Your Question
1

MoveIt demo.launch for custom arm trouble [closed]

asked 2013-09-26 07:23:01 -0600

I am in the process of setting up our CytonGamma300 to work with MoveIt. I've been doing my best to follow along with all the tutorials associated with constructing the URDF and running through the MoveIt setup assistant. Everything works great up until I try to run the demo.launch file created by the setup assistant. It looks like the move_group node dies during setup:

[move_group-4] process has died [pid 20831, exit code -4

As a result when MoveIt (I assume) says:

[ INFO] [1380215273.058350241]: Constructing new MoveGroup connection for group 'arm'

The error that follows says:

[ERROR] [1380215303.107930485]: Unable to connect to action server within allotted time

This seems totally reasonable since the move_group node died. So I tried running the move_group node while everything else was running. I got the same error about it dying:

[move_group-1] process has died [pid 21462, exit code -4

Obviously the next logical step was to see what was going on in the move_group.launch file. Thoughtfully enough there gdb options! So I enabled debugging and reran the launch file -- gdb and a quick backtrace give me this:

Program received signal SIGILL, Illegal instruction.
0x00007ffff263b86e in occupancy_map_monitor::OccupancyMapMonitor::OccupancyMapMonitor(boost::shared_ptr<tf::Transformer> const&, std::string const&, double) () from /opt/ros/hydro/lib/libmoveit_occupancy_map_monitor.so
(gdb) backtrace
#0  0x00007ffff263b86e in occupancy_map_monitor::OccupancyMapMonitor::OccupancyMapMonitor(boost::shared_ptr<tf::Transformer> const&, std::string const&, double) () from /opt/ros/hydro/lib/libmoveit_occupancy_map_monitor.so
#1  0x00007ffff694443c in planning_scene_monitor::PlanningSceneMonitor::startWorldGeometryMonitor(std::string const&, std::string const&) () from /opt/ros/hydro/lib/libmoveit_planning_scene_monitor.so
#2  0x000000000040e5d1 in main ()

Any ideas? I'm running hydro on ubuntu 12.04. RViz starts up just fine when I run demo.launch and after the above connection attempt times out I can move the arm goal configuration around in RViz.

I imagine this is related to the problem but in the Motion Planning box in the Context tab in the Planning Library pane "NO PLANNING LIBRARY LOADED" is displayed in red.

To further supply information (as a control) I tried running the pr2_moveit_config version of demo.launch and have possibly similar problems:

[move_group-5] process has died [pid 22281, exit code -4

and then

[ERROR] [1380216041.741668016]: The kinematics plugin (left_arm) failed to load. Error: According to the loaded plugin descriptions the class pr2_arm_kinematics/PR2ArmKinematicsPlugin with base class type kinematics::KinematicsBase does not exist. Declared types are  kdl_kinematics_plugin/KDLKinematicsPlugin

followed by the same message for the right_arm.

Thank you so much for your help with this!

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by skiesel
close date 2013-10-11 04:40:36

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-09-26 10:15:41 -0600

isucan gravatar image

It is possible this has to do with illegal instructions executed by moveit. This is because of some SSE instructions that are activated and should not be. This was fixed in source, but the moveit_ros_* packages (0.5.6) are only now being built.

edit flag offensive delete link more

Comments

https://github.com/ros-planning/moveit_ros/issues/318

isucan gravatar imageisucan ( 2013-09-26 10:16:08 -0600 )edit

Oh okay awesome! Thanks so much for the information. Do you have any idea of when the update might be released?

skiesel gravatar imageskiesel ( 2013-09-26 12:26:28 -0600 )edit

After the latest release everything is working great! Thanks!

skiesel gravatar imageskiesel ( 2013-10-03 03:17:35 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2013-09-26 07:23:01 -0600

Seen: 1,242 times

Last updated: Sep 26 '13