Ask Your Question
0

ROS kinetic on my Ubuntu 16.04 LTS install error

asked 2017-06-08 02:45:29 -0500

Pranav_Kumar gravatar image

updated 2017-06-08 03:23:12 -0500

gvdhoorn gravatar image

Hi, I'm a noob to linux and while installing ROS Kinetic on 16.04 LTS encountered this error

E: Sub-process /usr/bin/dpkg returned an error code (1)

Code before that
sudo apt-get install ros-kinetic-desktop-full
Reading package lists... Done
Building dependency tree       
Reading state information... Done
ros-kinetic-desktop-full is already the newest version (1.3.0-0xenial-20170430-131230-0800).
0 upgraded, 0 newly installed, 0 to remove and 196 not upgraded.
291 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable
Setting up libssl1.0.0:amd64 (1.0.2g-1ubuntu4.8) ...
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable
dpkg: error processing package libssl1.0.0:amd64 (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of libpq5:amd64:
 libpq5:amd64 depends on libssl1.0.0 (>= 1.0.0); however:
  Package libssl1.0.0:amd64 is not configured yet.

dpkg: error processing package libpq5:amd64 (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                          No apport report written because the error message indicates its a followup error from a previous failure.
                                                                     dpkg: dependency problems prevent configuration of libgdal1i:
 libgdal1i depends on libpq5; however:
  Package libpq5:amd64 is not configured yet.

dpkg: error processing package libgdal1i (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgazebo7:amd64:
 libgazebo7:amd64 depends on libgdal.so.1-1.11.3; however:
  Package libgdal.so.1-1.11.3 is not installed.
  Package libgdal1i which provides libgdal.so.1-1.11.3 is not configured yet.
 libgazebo7:amd64 depends on libgdal1i (>= 1.8.0); however:
  Package libgdal1i is not configured yet.

dpkg: error processing package libgazebo7:amd64 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libruby2.3:amd64:
 libruby2.3:amd64 depends on libssl1.0.0 (>= 1.0.2~beta3); however:
  Package libssl1.0.0:amd64 is not configured yet.

dpkg: error processing package libruby2.3:amd64 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of gazebo7:
 gazebo7 depends on libgazebo7 (= 7.0.0+dfsg-2); however:
  Package libgazebo7:amd64 is not configured yet.

dpkg: error processing package gazebo7 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gazebo7-plugin-base:
 gazebo7-plugin-base depends on libgazebo7; however:
  Package libgazebo7:amd64 is not configured yet.

dpkg: error processing package gazebo7-plugin-base (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              No apport report written because MaxReports is reached already
                                                                                                                            dpkg: dependency problems prevent configuration of libaprutil1:amd64:
 libaprutil1:amd64 depends on libssl1.0.0 (>= 1.0.0); however:
  Package libssl1.0.0:amd64 is not configured yet.

dpkg: error processing package libaprutil1:amd64 (--configure):
 dependency problems ...
(more)
edit retag flag offensive close merge delete

Comments

1

I should add that the first step would be to reboot the computer; your very first error message indicates a file is in use by another process, and issues cascade from there:

https://wiki.edubuntu.org/DebuggingIn...

Dale McConachie gravatar image Dale McConachie  ( 2017-06-08 10:59:40 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2017-06-08 10:57:30 -0500

Dale McConachie gravatar image

Sounds like dpkg is having issues independent of ROS, I would try the steps listed here https://stackoverflow.com/questions/2... and then following the error messages from there if problems persist.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2017-06-08 02:45:29 -0500

Seen: 1,586 times

Last updated: Jun 08 '17