ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Error in running "sudo rosdep init"

asked 2016-05-23 12:00:32 -0500

siddhesh gravatar image

updated 2016-05-24 01:39:04 -0500

I had previously installed ROS Jade distribution, I have uninstalled it and trying to install Indigo, while running sudo rosdep init I get following error :

ERROR: default sources list file already exists:
Please delete if you wish to re-initialize

As suggested in one of the answers I tried using sudo pip uninstall rosdep to uninstall previous version which gives sudo: pip: command not found

Is there any way to manually remove rosdep? running which rosdep gives me this /usr/bin/rosdep

I found this question on the same error


edit retag flag offensive close merge delete


Did you try doing what it says? Deleting the file /etc/ros/rosdep/sources.list.d/20-default.list and then running sudo rosdep init again?

spmaniato gravatar image spmaniato  ( 2016-05-23 13:04:08 -0500 )edit

it works for me. thanks

abhay2302 gravatar image abhay2302  ( 2016-10-21 01:00:59 -0500 )edit

hello there i am new to ROS and i facing the same problem etc/ros/rosdep/sources.list.d/20-default.list i cannot the file location to delete it. Can you please help??

rishityagi gravatar image rishityagi  ( 2018-05-13 06:32:51 -0500 )edit

sudo rm /etc/ros/rosdep/sources.list.d/20-default.list

Thanhdeptrai gravatar image Thanhdeptrai  ( 2020-11-22 01:43:43 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2016-05-24 02:03:24 -0500

gvdhoorn gravatar image

You don't need to uninstall rosdep, just make sure it's up to date.

rosdep isn't too tied to ROS releases, so it should work fine.

edit flag offensive delete link more


Thanks, it worked.

siddhesh gravatar image siddhesh  ( 2016-05-24 09:45:21 -0500 )edit

Question Tools

1 follower


Asked: 2016-05-23 12:00:32 -0500

Seen: 20,302 times

Last updated: May 24 '16