Ask Your Question
0

Error while trying to install ros kinetic on lubuntu 17.04

asked 2017-06-06 19:22:06 -0600

vivek87799 gravatar image

updated 2017-06-07 00:20:50 -0600

gvdhoorn gravatar image

I am getting the below error trying to install ros kinetic from the source.

Package libpng12-dev is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'libpng12-dev' has no installation candidate
ERROR: the following rosdeps failed to install
  apt: command [sudo -H apt-get install -y libpng12-dev] failed

I tried to install libpng12 dev from binary package but still I am getting the same error.

edit retag flag offensive close merge delete

Comments

Did you find any solution to this problem? The package libpng12-dev is actually replaced by libpng12-0 but even after installing that the error wouldn't go.

YusraAzhar gravatar imageYusraAzhar ( 2017-10-17 15:40:39 -0600 )edit

@YusraAzhar: ROS Kinetic is not supported on Ubuntu 17.04, as @ahendrix already answered below.

gvdhoorn gravatar imagegvdhoorn ( 2017-10-18 01:31:43 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2017-06-06 19:27:02 -0600

ahendrix gravatar image

updated 2017-06-07 12:40:25 -0600

Per the ROS Kinetic install page, ROS Kinetic is only supported on Ubuntu 15.10 and 16.04 and Debian Jessie. It looks like Ubuntu/Lubuntu 17.04 has different package versions and isn't compatible.

ROS Lunar is officially supported on Ubuntu 17.04, so I recommend that you install it instead.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-06-06 19:22:06 -0600

Seen: 471 times

Last updated: Jun 07 '17