Turtlebot amcl_demo.launch can't load my map

asked 2017-06-06 04:54:40 -0600

WilsonTang gravatar image

updated 2017-06-06 20:16:08 -0600

Hi everyone, I am a rookie to implement Turtlebot on ROS. I want to use navigation package to enable Turtlebot.My ROS version is KINETIC.

First, I use realsense zr300 camera to create a map and use map_sever to save the map. I have my_map.pgm and my_map.yaml file.

Second, I launch the amcl_demo.launch from Turtlebot_gazebo and there are some errors and warnings happen. I tried to implement this

roslaunch turtlebot_bringup minimal.launch
roslaunch turtlebot_navigation amcl_demo.launch map_file:=/tmp/my_map.yaml

or

roslaunch turtlebot_gazebo amcl_demo.launch map_file:=/tmp/my_map.yaml

The error and warning like this:

[map_server-2] process has died [pid 23511, exit code 255, cmd /opt/ros/kinetic/lib/map_server/map_ndserver /tmp/my_map.yaml __name:=map_server __log:=/home/wilson/.ros/log/867594de-4a99-11e7-8283-02095c506664/map_server-2.log]. log file: /home/wilson/.ros/log/867594de-4a99-11e7-8283-02095c506664/map_server-2*.log

and

[ WARN] [1496740896.137411129]: Timed out waiting for transform from base_footprint to map to become available before running costmap, tf error: . canTransform returned after 0.10146 timeout was 0.1.

Can Anyone help me to solve this problem?

Many Thanks

edit retag flag offensive close merge delete

Comments

What command did you use to launch amcl?

MarkyMark2012 gravatar imageMarkyMark2012 ( 2017-06-06 05:05:26 -0600 )edit

I tried this

roslaunch turtlebot_bringup minimal.launch
roslaunch turtlebot_navigation amcl_demo.launch map_file:=/tmp/my_map.yaml

and

roslaunch turtlebot_gazebo amcl_demo.launch map_file:=/tmp/my_map.yaml

Both have those errors and warnings.

WilsonTang gravatar imageWilsonTang ( 2017-06-06 09:14:59 -0600 )edit

Can't see anything obvious at the moment:

1) Ensure roslaunch turtlebot_bringup minimal.launch is fully up and running before launching amcl_demo.launch 2) Try moving both the map files from tmp to your home dir 3) Running the commands with --screen to get a better idea of what is going on/wrong

MarkyMark2012 gravatar imageMarkyMark2012 ( 2017-06-07 01:15:38 -0600 )edit

Did you find the solution for the same? I'm also having the same problem! Please help1

pmuthu2s gravatar imagepmuthu2s ( 2018-10-21 15:46:30 -0600 )edit