Ask Your Question
0

How can I use Realsense SR300

asked 2017-05-26 01:25:08 -0500

ant0520 gravatar image

updated 2017-08-09 16:45:51 -0500

130s gravatar image

Hi, I'm Japanese, so maybe my English is strange. Now, I want to use Intel Realsense SR300. I write my environment and please teach me what should I tell you about my PC because I'm beginner. OS : Ubuntu14.04 ROS ; Indigo Senser : RealsenseSR300 Kernel : 4.4.0-040400-generic

I write all commands I did.

$: sudo apt-get -y install libusb-1.0-0-dev git build-essential

$: git clone https://github.com/IntelRealSense/lib...

$: cd librealsense

$: git checkout tags/v0.9.2

$: scripts/install_glfw3.sh

$: make

$: sudo make install

$: sudo modprobe -r uvcvideo

$: sudo cp config/99-realsense-libusb.rules /etc/udev/rules.d/

$: sudo udevadm control --reload-rules

$: udevadm trigger

$: ./bin/cpp-capture

Then I have an error,

RealSense error calling rs_create_context(api_version:4): API version mismatch: librealsense.so was compiled with API version 1.12.1 but the application was compiled with 4! Make sure correct version of the library is installed (make install)

I installed "Docker" and I checked "client API version: 1.18". What should I do?? Thank you.

Edit: Improved readability

edit retag flag offensive close merge delete

Comments

Looks like you have two different versions of librealsense on your system. Please paste output of dpkg -l | grep realsense

Humpelstilzchen gravatar image Humpelstilzchen  ( 2017-05-26 02:42:40 -0500 )edit

Thank you your comment! I did that command and I past the result! $: dpkg -l | grep realsense ii ros-indigo-librealsense 1.12.1-1trusty-20170329-171250-0700 amd64 Library for capturing data from the Intel(R) RealSense(TM) F200, SR300, R200, LR

ant0520 gravatar image ant0520  ( 2017-05-28 20:10:41 -0500 )edit

Hey, do yo get any luck doing that? I'm not sure how to use the files under the example folder. Could you help me?

thompson104 gravatar image thompson104  ( 2017-07-13 20:59:26 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2017-05-29 00:31:27 -0500

Humpelstilzchen gravatar image

You have two different versions f the same library installed:

  1. The version of the package ros-indigo-librealsense

  2. The one that you compiled from source

What you are trying to do is running cpp-capture (source version) with the binary library from ubuntu. Uninstall either version.

edit flag offensive delete link more

Comments

Thanks!! I could connect SR300!!

ant0520 gravatar image ant0520  ( 2017-05-29 19:44:15 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2017-05-26 01:25:08 -0500

Seen: 703 times

Last updated: May 29 '17