ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

How to connect VLP-16 (confused about the tutorial)

asked 2017-05-09 11:31:18 -0600

T318forever gravatar image

updated 2023-06-18 10:01:10 -0600

lucasw gravatar image

I try to connect VLP-16 to indigo in four ways, but all failed and led to the same result (no data was printed through command "rostopic echo /velodyne_points" and "rostopic echo /velodyne_packets"):

First method, refer to tutorial about VLP-16

1 Access the Gnome Menu (Super key), type "Networks Connections" then run it.

2 Select the connection's name and click on "edit".

3 Choose the IPV4 Settings tab and change the “Method” field to "Manual". Set as below, according to :

image description

Is the setting correct?

4 sudo ifconfig eth0

5 I don't what it means in tutorial: "Add a static route to the LIDAR's IP address. The IP address can be found on the CD case which was included with the LIDAR. sudo route add 192.168.XX.YY eth0", since I don't have a CD. What should XX and YY be? Or can I skip this step?

Second method:

1 sudo route add eth0 (Without turning off wire and change the settings in "Network Connections")

Third method:

1 sudo ifconfig eth0 (Without turning off wire and change the settings in "Network Connections")

Fourth method: 1. sudo ifconfig eth0

  1. sudo route add eth0

After any of the methods,

I applied:

$ roscore

change to the correct workspace

$source devel/setup.bash

$ roslaunch velodyne_pointcloud VLP16-points.launch

Then, $ rostopic echo /velodyne_points

$ rostopic echo /velodyne_packets

no data was printed from any command above


rosrun rviz rviz -f velodyne

After open the interface: image description "No tf data. Actual error: Fixed frame [velodyne] doesn't exist"

So, what's wrong with the connection to VLP 16? Can you provide me with a detailed and correct way to connect VLP 16 to indigo (Don't mention the tutorial. It is based on HDL-32E)?

Thanks for you all!

edit retag flag offensive close merge delete

3 Answers

Sort by » oldest newest most voted

answered 2017-10-03 19:59:21 -0600

fiorano10 gravatar image

I don't think your Velodyne is connected, can you access the Velodyne interface on a browser ? The default IP address is Looking at your screenshots, you have the name of the connection wrong, the connection has to be eth0. Change that and everything should work. Also, you need to add a pointcloud2 topic in Rviz, then double click pointcloud2 and from the drop down of topics, select /velodyne_points. You should be able to see your pointcloud then.

edit flag offensive delete link more


How to access the Velodyne interface on a broswer? I have entered the IP address in the browser, it shows can not found, how to change? thank you.

summer gravatar image summer  ( 2018-01-02 01:03:15 -0600 )edit

Okay, what if you enter in the browser? Although, the default VLP-16 IP address is You should try this to see which devices are connected.

fiorano10 gravatar image fiorano10  ( 2018-01-02 13:25:22 -0600 )edit

ok , I do that, however, it dosen't work. the screen also shows NOT FOUND. What should I do?

summer gravatar image summer  ( 2018-01-02 19:04:33 -0600 )edit

What is the IP address of the VLP-16? You should know that once you see a list of connected devices. And once you figure the IP address, just type in the terminal and the Velodyne interface will open.

fiorano10 gravatar image fiorano10  ( 2018-01-02 19:08:23 -0600 )edit

I should enter in browser or terminal?

summer gravatar image summer  ( 2018-01-02 19:13:09 -0600 )edit

answered 2017-08-27 21:54:29 -0600

jmabreo gravatar image

updated 2017-10-03 17:56:15 -0600

jayess gravatar image

To solve the problem of the "fixed frame" you have to define the transformation first. Before opening rviz you have to use the tf package according to the instructions at

tf is used to "maintains the relationship between coordinate frames in a tree structure buffered in time".

According to the instructions I am using the following command and it worked for me.

rosrun tf static_transform_publisher 0.0 0.0 0.0 0.0 0.0 0.0 map velodyne 100
edit flag offensive delete link more

answered 2017-10-03 16:49:54 -0600

rohanpaleja27 gravatar image

Just finished the same issue. In RVIZ click on fixed frame. Then click add and subscribe to the velodyne pointcloud.

edit flag offensive delete link more

Question Tools



Asked: 2017-05-09 11:31:18 -0600

Seen: 9,219 times

Last updated: Oct 03 '17