Ask Your Question
0

'rosnode list' does not show the roscore in other computer.

asked 2011-04-02 22:40:29 -0500

Hyon Lim gravatar image

I installed Ubuntu 10.04 on two different Virtual Box.

I set the network mode as Bridge, that retrieves IP address from my router (Apple Airport).

The machine #1 has 10.0.1.24 The machine #2 has 10.0.1.25.

I ran the roscore in machine #1. And 'rosnode list' on machine #2.

But I don't know why roscore of machine #1 does not show up in machine #2.

edit retag flag offensive close merge delete

Comments

Can you edit your question to explain exactly what you're seeing and what you expect the output to be. roscore is not itself a node and will not show up on rosnode list.
tfoote gravatar image tfoote  ( 2011-04-03 13:28:15 -0500 )edit

3 Answers

Sort by » oldest newest most voted
1

answered 2011-04-03 08:48:15 -0500

fergs gravatar image

updated 2011-04-03 08:48:52 -0500

You need to set ROS_MASTER_URI as Martin said, but you may also need to set ROS_HOSTNAME. See http://www.ros.org/wiki/ROS/Tutorials/MultipleMachines for a full tutorial.

edit flag offensive delete link more

Comments

Thanks. Works well.
Hyon Lim gravatar image Hyon Lim  ( 2011-04-03 18:33:12 -0500 )edit
0

answered 2011-04-03 18:31:47 -0500

Hyon Lim gravatar image

Thank you. I can connect to roscore from machine #2. But, another problem.

I would like to control turtle (turtlesim example) in #1 using #2 keyboard.

So in #1,

$ rosrun turtlesim turtlesim_node

And in #2,

$ rosrun turtlesim turtle_teleop_key

However, I couldn't control. And I also ran the 'rxgraph' util, it seems not connected.

What's the problem?

edit flag offensive delete link more

Comments

For the record, the original asker asked this as a new question here: http://answers.ros.org/question/600/i-cannot-control-a-turtle-spawned-in-another
Martin Günther gravatar image Martin Günther  ( 2011-04-04 02:27:44 -0500 )edit
0

answered 2011-04-03 00:46:11 -0500

First, ensure that port 11311 on machine #1 is reachable from machine #2. Then, you have to set the environment variable ROS_MASTER_URI appropriately. In your setup, run the following commands in a terminal on machine #2:

export ROS_MASTER_URI=http://10.0.1.24:11311
rosnode list

The first line has to be executed in each terminal that is supposed to connect to the master on machine #1. Alternatively, you can add it to your ~/.bashrc file (assuming your shell is Bash), and close and re-open all running terminals.

edit flag offensive delete link more

Comments

Thanks! Works well!!
Hyon Lim gravatar image Hyon Lim  ( 2011-04-03 18:33:19 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-04-02 22:40:29 -0500

Seen: 1,413 times

Last updated: Apr 03 '11