Ask Your Question
0

StereoCalibration GUI doesn't start.

asked 2017-04-24 11:54:54 -0500

RaduM17 gravatar image

This is the message displayed in the console:

rosrun camera_calibration cameracalibrator.py --size 8x6 --square 0.108 right:=/optris/thermal_binary left:=/camera/rgb/image_rect_color left_camera:=/camera/rgb right_camera:=/optris ('Waiting for service', '/camera/rgb/set_camera_info', '...') OK ('Waiting for service', '/optris/set_camera_info', '...') OK

And nothig happens. Mono calibration worked well for both camera camera_calibration cameracalibrator.py --size 8x6 --square 0.108 image:=/optris/thermal_binary camera:=/optris camera_calibration cameracalibrator.py --size 8x6 --square 0.108 image:=/camera/rgb/image_rect_color camera:=/camera/rgb

edit retag flag offensive close merge delete

Comments

1

Stereo calibration for separate cameras requires that the two cameras are synchronised. Are the timestamps of the messages from each camera the same?

Geoff gravatar image Geoff  ( 2017-04-24 20:25:19 -0500 )edit

They are synchronised.

RaduM17 gravatar image RaduM17  ( 2017-04-25 03:44:16 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-05-21 19:13:03 -0500

naveenT1010 gravatar image

I was also getting a blank gui until I tried with the --approximate argument. Try using
--approximate=0.1 or 0.3
along with your command.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2017-04-24 11:54:54 -0500

Seen: 149 times

Last updated: May 21 '17