Ask Your Question
0

Problem with stereo and monocular calibration on openni_kinect

asked 2012-08-01 05:16:07 -0500

Fer Nunez gravatar image

updated 2016-10-24 09:03:02 -0500

ngrennan gravatar image

Hello, Im trying to get my kinect stereo calibrate so I was following this tutorial:

http://www.ros.org/wiki/camera_calibration/Tutorials/StereoCalibration#Before_Starting

but when I try $ rostopic list, it doesn't show any of the /my_stereo.../ and when I tried

rosrun camera_calibration cameracalibrator.py --size 8x6 --square 0.108 right:=/my_stereo/right/image_raw left:=/my_stereo/left/image_raw right_camera:=/my_stereo/right left_camera:=/my_stereo/left

I got: "Waiting for service /my_stereo/left/set_camera_info ... Service not found Waiting for service /my_stereo/right/set_camera_info ... Service not found"

I also tried the Monocular Camera calibration on: http://www.ros.org/wiki/camera_calibration/Tutorials/MonocularCalibration and got the same problem "Waiting for service /camera/set_camera_info ... Service not found" with $ rosrun camera_calibration cameracalibrator.py --size 8x6 --square 0.108 image:=/camera/image_raw camera:=/camera

What im doing wrong? What should I do? Im working on ubuntu 12.04 and ros fuerte.

thanks!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-08-01 05:24:47 -0500

updated 2012-08-01 05:26:18 -0500

The kinect is not a (traditional) stereo camera, so the stereo calibration will not work. There is a wiki page which details how to calibrate a kinect properly.

There isn't quite enough information to figure out why the set_camera_info service can't be found. Could you edit your question to add the exact command you're using the launch the camera driver?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-08-01 05:16:07 -0500

Seen: 605 times

Last updated: Aug 01 '12