Ask Your Question
0

Unable to run cameracalibrator.py

asked 2013-01-19 16:14:41 -0500

mhariharasudan gravatar image

Hi, I want to calibrate two individual cameras as a stereocamera. So i tried running the file cameracalibrator.py from the path /opt/ros/fuerte/stackes/image_pipeline/camera_calibration/nodes.

Im getting an error
File "/opt/ros/fuerte/stacks/image_pipeline/camera_calibration/nodes/cameracalibrator.py", line 42, in <module> from camera_calibration.approxsync import ApproximateSynchronizer

I could not find this module camera_calibration.approxsync located anywhere. Kindly let me know where i am missing

Thanks in advance

edit retag flag offensive close merge delete

Comments

I am also facing the same issue..any solution?

sai gravatar image sai  ( 2013-05-13 23:05:15 -0500 )edit

perfect..thank you so much. Later I had the issue with import cv_bridge and solved that by adding the path to cv_bridge to pythonpath...

sai gravatar image sai  ( 2013-05-14 23:32:48 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-05-13 23:13:02 -0500

mhariharasudan gravatar image

search for appoxsync in your camera_calibration package. Then place it in the same folder as your source file. Replace the line "from camera_calibration.approxsync" with "from approxsync" and this should work. Let me know if you have any issues in this

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-01-19 16:14:41 -0500

Seen: 527 times

Last updated: Jan 19 '13