Ask Your Question
0

terminate called after throwing an instance of 'boost: Permission denied'

asked 2017-04-17 23:29:56 -0600

Awais gravatar image

While running roslaunch ca_driver create_2.launch I receive this error. I have used the command for $ sudo usermod -a -G dialout $administartor, logged out and logged in again but it still doesn't work.

terminate called after throwing an instance of 'boost::exception_detail::clone_impl<boost::exception_detail::error_info_injector<boost::system::system_error> >' what(): open: Permission denied

[ca_driver-2] process has died [pid 7759, exit code -6, cmd /home/administrator/create_ws/devel/lib/ca_driver/ca_driver __name:=ca_driver __log:=/home/administrator/.ros/log/f3f9e360-23ee-11e7-a992-f46d04793b72/ca_driver-2.log]. log file: /home/administrator/.ros/log/f3f9e360-23ee-11e7-a992-f46d04793b72/ca_driver-2*.log

Please help. Thanks

edit retag flag offensive close merge delete

Comments

Can you post the output of ls /dev/tty*? Which robot base are you using? Create 2?

jacobperron gravatar imagejacobperron ( 2017-04-18 01:17:59 -0600 )edit

Thank you for your response. I am using Create 2 directly connected to computer via USB cable. Actually I am just beginning to work on ROS and Ubuntu and doesn't know how to check the output at "ls /dev/tty*". When I try with the code with USB cable removed it gives the same error: No such file or d

Awais gravatar imageAwais ( 2017-04-18 15:15:43 -0600 )edit

"No such file or directory". I have also tried launching Create 1 it also returns the same error with: Permission denied. The rostopics being published are : /diagnostics /joint_states /rosout /rosout_agg /tf /tf_static

Awais gravatar imageAwais ( 2017-04-18 15:17:26 -0600 )edit
  1. Connect the cable to your computer and robot
  2. Make sure the robot is powered on (main LED should be green)
  3. Open a terminal and run the command ls /dev/tty*. Copy and paste the output here.

Are you using a virtual machine by chance?

jacobperron gravatar imagejacobperron ( 2017-04-18 17:17:16 -0600 )edit

It gives the following list /dev/tty /dev/tty23 /dev/tty39 /dev/tty54 /dev/ttyS10 /dev/ttyS26... ...../dev/ttyS9 /dev/tty2 /dev/tty35 /dev/tty50 /dev/tty9 /dev/ttyS22 /dev/ttyUSB0

This /dev/tty/USB0 goes off when I remove the cable and shows again when I plug in th cable ag

Awais gravatar imageAwais ( 2017-04-18 22:25:39 -0600 )edit

Thanks for your help. It is working for me now. I think there was authorization problem. I run the this command $ sudo -s and then this $source ~/create_ws/devel/setup.bash and launched create_2 which is now working. Thanks.

Awais gravatar imageAwais ( 2017-04-19 01:12:03 -0600 )edit

Glad you hear it's working.

jacobperron gravatar imagejacobperron ( 2017-04-19 11:03:56 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-05-31 00:58:18 -0600

fj138696 gravatar image

Every time I got this error, i will just to run

sudo chmod a+rw /dev/ttyUSB0

then create_autonomy will work. But I makes me wonder how to permanently add this USB permission to Ubuntu?

edit flag offensive delete link more

Comments

2

Try sudo usermod -a -G dialout $USER and then logout/login. (reference)

jacobperron gravatar imagejacobperron ( 2017-05-31 12:15:19 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-04-17 23:29:56 -0600

Seen: 1,484 times

Last updated: May 31 '17