Compilation problem with navigation package in kinetic [closed]

asked 2017-03-23 05:08:11 -0500

peterwe gravatar image

updated 2017-03-23 08:35:09 -0500

I am using ROS Kinetic on Ubuntu 16.04. I have the navigation package and some other stuff in my workspace. When I do catkin_make in my workspace it builds till 100% and then just stops and does nothing until I kill it.

This is what appears in the terminal after I press Ctrl+C:

make[2]: *** Deleting file '/home/robot/catkin_ws/devel/lib/costmap_2d/costmap_2d_markers'
make[2]: *** Deleting file '/home/robot/catkin_ws/devel/lib/costmap_2d/costmap_2d_cloud'
Traceback (most recent call last):
File "/opt/ros/kinetic/bin/catkin_make", line 296, in <module>
File "/opt/ros/kinetic/bin/catkin_make", line 240, in main
run_command(cmd, make_path)
File "/opt/ros/kinetic/lib/python2.7/dist-packages/catkin/", line 239, in run_command
File "/usr/lib/python2.7/", line 1392, in wait
pid, sts = _eintr_retry_call(os.waitpid,, 0)
File "/usr/lib/python2.7/", line 476, in _eintr_retry_call
return func(*args)
navigation/costmap_2d/CMakeFiles/costmap_2d_cloud.dir/build.make:541: recipe for target '/home/robot/catkin_ws/devel/lib/costmap_2d/costmap_2d_cloud' failed
navigation/costmap_2d/CMakeFiles/costmap_2d_markers.dir/build.make:541: recipe for target '/home/robot/catkin_ws/devel/lib/costmap_2d/costmap_2d_markers' failed
make[2]: *** [/home/robot/catkin_ws/devel/lib/costmap_2d/costmap_2d_cloud] Interrupt
make[2]: *** [/home/robot/catkin_ws/devel/lib/costmap_2d/costmap_2d_markers] Interrupt
CMakeFiles/Makefile2:11075: recipe for target 'navigation/costmap_2d/CMakeFiles/costmap_2d_cloud.dir/all' failed
make[1]: *** [navigation/costmap_2d/CMakeFiles/costmap_2d_cloud.dir/all] Interrupt
CMakeFiles/Makefile2:11114: recipe for target 'navigation/costmap_2d/CMakeFiles/costmap_2d_markers.dir/all' failed
make[1]: *** [navigation/costmap_2d/CMakeFiles/costmap_2d_markers.dir/all] Interrupt
Makefile:138: recipe for target 'all' failed
make: *** [all] Interrupt

Any help would be appreciated!

edit: A new set up of ROS and my workspace solved the problem.

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by peterwe
close date 2017-04-13 07:26:56.102422


Compiling that package requires quite some memory. Are you attempting this on an ARM / other embedded platform / inside a VM? Please always include information on the platform your trying to do things on.

gvdhoorn gravatar image gvdhoorn  ( 2017-03-23 07:21:14 -0500 )edit

It worked well on Ubuntu 14.04 and ROS Indigo before. I wiped everything related to ROS and my workspace and setting it up again. I hope this solves my problem. edit: I work on an Odroid XU4.

peterwe gravatar image peterwe  ( 2017-03-23 08:22:15 -0500 )edit