Gazebo crashes on self collide: Param.cc 'inf'

asked 2017-03-13 21:16:29 -0600

ufr3c_tjc gravatar image

Hi guys.

I was altering some minor values in our URDF and now Gazebo crashes shortly after startup. I was only changing small things, like controller PID's, friction and damping etc, and only minor alterations of probably +/- 20%. When launching Gazebo without the ros_control controllers running, the program crashes when the boom slowly falls and touches the blade (our robot is a small excavator). The error output is shown below (comes up 20 times per crash):

Error [Param.cc:451] Unable to set value [inf inf -inf -2.15675 -0.36903 -0.86877] for key[pose]
Error [Param.cc:451] Unable to set value [inf inf -inf -1.62554 -1.12305 -1.90234] for key[pose]
Error [Param.cc:451] Unable to set value [inf inf -inf -1.30275 0.434637 2.40115] for key[pose]
Error [Param.cc:451] Unable to set value [inf inf -inf 0.956331 -0.661333 -2.4084] for key[pose]
Error [Param.cc:451] Unable to set value [inf inf inf -1.15322 0.249827 -0.069431] for key[pose]
Error [Param.cc:451] Unable to set value [inf inf inf 3.07698 0.590642 1.29578] for key[pose]

The same error occurs when you turn the controllers on. You may be able to move the robot for a bit before it self-collides and then it crashes. Everything seems to work fine until a self-collision happens, but just a few hours ago everything was fine. Self collision is turned off for all the links, but we tried on/off combinations with no luck.

Ubuntu 16.04 with Kinetic and Gazebo 7. Willing to try any possible solutions you think of. Cheers guys.

edit retag flag offensive close merge delete

Comments

Hello. Have you found the solution of this problem? I am also facing the same problem.

Mifta gravatar image Mifta  ( 2018-02-06 03:53:39 -0600 )edit

If I remember correctly it was because we had no inertia values for our links, so when applying the force due to the links hitting, the force was applied against a link with zero mass/inertia. This results in an 'infinite' acceleration and hence infinite pose. So make sure you have inertias.

ufr3c_tjc gravatar image ufr3c_tjc  ( 2018-02-06 16:24:04 -0600 )edit

Any break through? I am also facing same error. My robot model collapses into ground, when I load the controllers.

dpakshimpo gravatar image dpakshimpo  ( 2018-04-09 02:25:23 -0600 )edit

Make sure you have realistic inertia and mass values. Also make sure you don't have any super-heavy links attached to light links, as this caused us problems recently. Also make sure you have a bit of friction and damping on the joints, as this makes things works better.

ufr3c_tjc gravatar image ufr3c_tjc  ( 2018-04-09 15:56:15 -0600 )edit

I'm also facing the same problem .

Wajdi gravatar image Wajdi  ( 2018-04-12 11:47:16 -0600 )edit

I would really recommend all of you post over at answers.gazebosim.org. Seeing Param.cc mentioned indicates this is probably a Gazebo problem, not a ROS one.

gvdhoorn gravatar image gvdhoorn  ( 2018-04-12 11:55:53 -0600 )edit