Ask Your Question
0

Tutorial "Writing a Simple Service and Client", i modified the wrong file, what can i do?

asked 2017-03-08 05:22:10 -0500

w.fradin gravatar image

updated 2017-03-08 07:25:17 -0500

gvdhoorn gravatar image

Hey,

I wish to learn ros and I started by doing the tutorials available on ros.org .

But in the "Writing a Simple Service and Client" tutorial, when it say to modify the file ~/catkin_ws/src/beginner_tutorials/CMakeLists.txt. I modified the secure file that is in ~/catkin_ws/src using sudo gedit CMakeLists. Before that, it worked but now I have a mistake when I do catkin_make.

CMake Error at /opt/ros/kinetic/share/genmsg/cmake/genmsg-extras.cmake:94 (message): add_message_files() directory not found: /home/audensiel/catkin_ws/src/msg

Call Stack (most recent call first): CMakeLists.txt:9 (add_message_files)

-- Configuring incomplete, errors occurred! See also "/home/audensiel/catkin_ws/build/CMakeFiles/CMakeOutput.log". See also "/home/audensiel/catkin_ws/build/CMakeFiles/CMakeError.log". Invoking "cmake" failed

When I remove all files and folders and I restart at the beginning (the tutorials), and i created mkdir -p ~/catkin_ws/src ... The file I modified previously is always the same. I think this is my problem, so if someone can give me the contents of this file or tell me how to retrieve the original.

Thank for your help.

William

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-03-08 07:28:20 -0500

gvdhoorn gravatar image

updated 2017-03-08 07:30:22 -0500

Please see #q227161 (but replace indigo withkinetic, obviously).

edit flag offensive delete link more

Comments

Thank a lot, problem solved !

w.fradin gravatar image w.fradin  ( 2017-03-08 07:38:16 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-03-08 05:22:10 -0500

Seen: 67 times

Last updated: Mar 08 '17