Ask Your Question
0

Xsens MTi-G 710 and robot_localization

asked 2017-03-01 08:07:27 -0500

EdCherie gravatar image

updated 2017-03-06 09:18:46 -0500

EDIT I am restructurizing the question because i made some progress but still stuck at one problem.

Hey guys, I am trying to implement Xsens INS device with robot_localization package that i could make robot navigate by GPS coordinates. However, i cannot get any data from navsat_transform node in the robot_localization package. I did find few suggestions what to do but it seems other people are more advanced than me so i got stuck at this point.

    <launch>
<!-- Parameters setting of the node: ekf_localization_node -->
  <node pkg="tf" type="static_transform_publisher" name="imu_tf" args="0 0 0 0 0 0 1 base_link base_imu 20"/>
  <node pkg="tf" type="static_transform_publisher" name="gps_tf" args="0 0 0 0 0 0 1 base_link imu 20"/>
  <node pkg="robot_localization" type="ekf_localization_node" name="ekf_localization" clear_params="true">
      <param name="output_frame" value="odom"/>
      <param name="frequency" value="20"/>
      <param name="odom_used" value="true"/>
      <param name="imu_used" value="true"/>
      <param name="vo_used" value="false"/>  
      <param name="sensor_timeout" value="0.1"/>  
      <param name="two_d_mode" value="false"/>

      <param name="map_frame"       value="map"/>
      <param name="odom_frame"      value="odom"/>
      <param name="base_link_frame" value="base_link"/>
      <param name="world_frame"     value="odom"/>

      <param name="odom0" value="odom"/>
      <param name="imu0"  value="/imu/data"/> 

      <rosparam param="odom0_config">[true, true, true,
                                      false, false, false, 
                                      false , false, false, 
                                      false, false, false,
                                      false, false, false]</rosparam>

      <rosparam param="imu0_config">[false, false, false, 
                                     true , true , true, 
                                     false, false, false, 
                                     true , true , true ,
                                     true , true , true ]</rosparam>

      <param name="odom0_differential" value="false"/>
      <param name="imu0_differential"  value="false"/>

      <param name="imu0_remove_gravitational_acceleration" value="true"/>

      <param name="odom0_relative" value="false"/>
      <param name="imu0_relative"  value="false"/>

      <param name="print_diagnostics" value="true"/>

       <!-- ======== ADVANCED PARAMETERS ======== -->

      <param name="odom0_queue_size" value="2"/>
      <param name="imu0_queue_size" value="10"/>

      <rosparam param="process_noise_covariance">[0.05, 0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0,
                                              0.0, 0.05, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0,
                                              0.0, 0.0, 0.06, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0,
                                              0.0, 0.0, 0.0, 0.03, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0,
                                              0.0, 0.0, 0.0, 0.0, 0.03, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0,
                                              0.0, 0.0, 0.0, 0.0, 0.0, 0.06, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0,
                                              0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.025, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0,
                                              0.0, 0.0, 0.0, 0.0, 0.0, 0.0 ...
(more)
edit retag flag offensive close merge delete

Comments

Please post sample input messages from all sensors.

Tom Moore gravatar imageTom Moore ( 2017-03-01 08:24:07 -0500 )edit

Updated the initial question

EdCherie gravatar imageEdCherie ( 2017-03-06 09:19:01 -0500 )edit

Yeah, that was the problem. Xsens was using older version tf than localization.

EdCherie gravatar imageEdCherie ( 2017-03-14 06:06:07 -0500 )edit

Tom's comment out frame_id was the solution

EdCherie gravatar imageEdCherie ( 2017-03-14 06:06:32 -0500 )edit

I've promoted that to an answer, which you can accept. Thanks!

Tom Moore gravatar imageTom Moore ( 2017-03-14 06:24:12 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-03-14 05:47:53 -0500

Tom Moore gravatar image

Can you please change the frame_id in your input messages from /imu to imu (get rid of the slash) and try again?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2017-03-01 08:07:27 -0500

Seen: 406 times

Last updated: Mar 14 '17