Getting Skeleton Tracker work on ASUS Xtion Pro Live

asked 2017-02-16 06:30:35 -0500

James7 gravatar image

I spent the last couple of weeks (2 weeks to be specific) trying to make sense of everything related with having an RGB-D camera working with ROS and then having a Skeleton Tracker working with the sensor.

Although the community is amazingly perfect, I had no luck getting Skeleton Tracker working with any of my sensor. I started with Microsoft Kinect One (v2) and after long time spent on it, I switched to ASUS Xtion Pro Live with the hope, I will find something working for it. Unfortunately I didn't!

I know you are looking for specific errors and logs, but I am lost, I tried EVERY single library out there! Non works. I can't get skeleton tracker working.

I tried the following libraries:

I am working on a project with a deadline and as time passes and I can't have the sensor working the worst. I am in a state where I am not sure (1) if is just the libraries not perfect and they are not working with the sensors I have (2) I do something wrong.

I would appreciate if someone can help me by giving some hints of what process to follow and if s/he saw the specific (ASUS Xtion Pro Live) sensor working with ROS and Rviz.

I have read almost all ROS Answers regarding similar problems, and the process I am reading and I am following is the same, download OpenNI2 and then NiTE2.0.0 ir NiTE1.5 etc run the sudo ./install.sh then build etc. Never worked although I follow steps highlighted in the libraries READMEs.

edit retag flag offensive close merge delete

Comments

Hi, if you can use a Kinect v1, skeleton tracking works fine with it, with the package openni_tracker. Good luck!

Cyril_J gravatar image Cyril_J  ( 2017-02-16 09:13:27 -0500 )edit