Error: Unsupported color video mode - Resolution: 640x480@30Hz Format: RGB888

asked 2016-01-08 10:05:11 -0500

adarsh.modh gravatar image

updated 2016-01-08 10:52:50 -0500

Hey, I am a beginner on ROS, I have installed ROS Indigo on Ubuntu 14.04 and I was trying to interface an Asus Xtion Pro with it using OpenNI 2...... I have installed ROS following the steps given in http://wiki.ros.org/indigo/Installati... . I have set the environment in the bashrc file and also have created catkin workspace....... So after reading a few things I wasn't sure whether to use openNI or openNI 2..... so i tried both.....and I have been getting errors on both of them...... but the error when i launched openNI 2 seemed more precise so this is what I get:

SUMMARY

adarsh@adarsh-OptiPlex-980:~$ roslaunch openni2_launch openni2.launch
... logging to /home/adarsh/.ros/log/a3ddee60-b614-11e5-8dbe-782bcb81705d/roslaunch-adarsh-OptiPlex-980-19261.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://adarsh-OptiPlex-980:41160/

PARAMETERS
 * /camera/camera_nodelet_manager/num_worker_threads: 4
 * /camera/depth_rectify_depth/interpolation: 0
 * /camera/driver/auto_exposure: True
 * /camera/driver/auto_white_balance: True
 * /camera/driver/color_depth_synchronization: False
 * /camera/driver/depth_camera_info_url: 
 * /camera/driver/depth_frame_id: camera_depth_opti...
 * /camera/driver/depth_registration: False
 * /camera/driver/device_id: #1
 * /camera/driver/rgb_camera_info_url: 
 * /camera/driver/rgb_frame_id: camera_rgb_optica...
 * /rosdistro: indigo
 * /rosversion: 1.11.16

NODES
  /camera/
    camera_nodelet_manager (nodelet/nodelet)
    depth_metric (nodelet/nodelet)
    depth_metric_rect (nodelet/nodelet)
    depth_points (nodelet/nodelet)
    depth_rectify_depth (nodelet/nodelet)
    depth_registered_sw_metric_rect (nodelet/nodelet)
    driver (nodelet/nodelet)
    points_xyzrgb_sw_registered (nodelet/nodelet)
    rectify_color (nodelet/nodelet)
    register_depth_rgb (nodelet/nodelet)
  /
    camera_base_link (tf/static_transform_publisher)
    camera_base_link1 (tf/static_transform_publisher)
    camera_base_link2 (tf/static_transform_publisher)
    camera_base_link3 (tf/static_transform_publisher)

ROS_MASTER_URI=http://localhost:11311

core service [/rosout] found
process[camera/camera_nodelet_manager-1]: started with pid [19279]
process[camera/driver-2]: started with pid [19280]
process[camera/rectify_color-3]: started with pid [19281]
process[camera/depth_rectify_depth-4]: started with pid [19282]
process[camera/depth_metric_rect-5]: started with pid [19283]
process[camera/depth_metric-6]: started with pid [19284]
process[camera/depth_points-7]: started with pid [19285]
process[camera/register_depth_rgb-8]: started with pid [19286]
process[camera/points_xyzrgb_sw_registered-9]: started with pid [19287]
process[camera/depth_registered_sw_metric_rect-10]: started with pid [19288]
process[camera_base_link-11]: started with pid [19289]
process[camera_base_link1-12]: started with pid [19290]
process[camera_base_link2-13]: started with pid [19291]
process[camera_base_link3-14]: started with pid [19292]
[ INFO] [1452267796.067754911]: Initializing nodelet with 4 worker threads.
[ INFO] [1452267798.786920410]: Device "1d27/0600@2/6" found.
***Warning: USB events thread - failed to set priority. This might cause loss of data...
[ERROR] [1452267799.064091351]: Unsupported color video mode - Resolution: 640x480@30Hz Format: RGB888***
^C[camera_base_link3-14] killing on exit
[camera_base_link2-13] killing on exit
[camera_base_link1-12] killing on exit
[camera_base_link-11] killing on exit
[camera/depth_registered_sw_metric_rect-10] killing on exit
[camera/points_xyzrgb_sw_registered-9] killing on exit
[camera/register_depth_rgb-8] killing on exit
[camera/depth_points-7] killing on exit
[camera/depth_metric-6] killing on exit
[camera/depth_metric_rect-5] killing on exit
[camera/depth_rectify_depth-4] killing on exit
[camera/rectify_color-3] killing on exit
[camera/camera_nodelet_manager-1] killing on exit
[camera/driver-2] killing on exit
shutting down processing monitor...
... shutting down processing monitor complete
done
adarsh@adarsh-OptiPlex-980:~$ ls usb
ls: cannot access usb: No such file or directory
adarsh@adarsh-OptiPlex-980:~$ lsusb
Bus 002 Device 006: ID 1d27:0600 ASUS 
Bus 002 Device 004: ID 413c ...
(more)
edit retag flag offensive close merge delete

Comments

I'm getting the same error... well, a similar one.
Here's where I talk about it: /link text

joe.s gravatar imagejoe.s ( 2016-02-22 11:22:11 -0500 )edit

Exactly the same problem, i don't find the solution yet...

Rastafouille gravatar imageRastafouille ( 2016-02-26 09:01:29 -0500 )edit