Ask Your Question
0

Asus XTion Pro Live on embedded Linux using OpenNI2?

asked 2014-10-22 01:49:26 -0600

Myzhar gravatar image

updated 2014-10-22 08:42:33 -0600

Hi, I'm going to use Asus XTion Pro Live (0601) on my robot running ROS Indigo on a NVidia Jetson TK1, but I have problems receiving data from the sensor. I installed openni2_launch and run it, the sensor is correctly recognized, but no data messages (both RGB and 3D) are generated. I tried it on both USB 2.0 and USB3.0 ports, on the first it is not detected, on the second it is detected, but it does not send data.

Any idea?

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
1

answered 2014-10-22 11:50:04 -0600

Hansg91 gravatar image

I usually find it worthwhile to compile OpenNI2 myself. For some reason I seem to be experiencing problems using the precompiled versions. It could be worth a shot at least..

Also it is worth a shot to try the samples of OpenNI2. In case you don't have a graphical interface, I believe SimpleRead doesn't open a window and just outputs some data from the camera. Then you know at least that it is connected and functional.

ps. I am running OpenNI2 with the Xtion on an Odroid U2 so I am pretty sure it should work on the Jetson TK1.

edit flag offensive delete link more

Comments

1

If you have trouble with the precompiled OpenNI2 binaries, PLEASE let me know. If you're having trouble, someone else probably is as well, and I can't fix things if I don't know that they're broken.

ahendrix gravatar imageahendrix ( 2014-10-22 12:53:57 -0600 )edit

Just to clarify, these are the OpenNI2 libraries, not the openni2 package from ROS. In addition, it was a long time ago, but I believe I had the same problem as @Myzhar, it just wouldn't find the Xtion.

Hansg91 gravatar imageHansg91 ( 2014-10-22 13:48:01 -0600 )edit

I tune and build a significant number of the dependencies for the ARM builds by hand, including OpenNI and OpenNI2.

ahendrix gravatar imageahendrix ( 2014-10-22 13:59:58 -0600 )edit

I tried only the version of OpenNI2 coming from the repository together with openni2_lauch.

Now I would like to remove this OpenNI2 version and to compile it by myself, but I do not know two things: 1) how to remove the package and its dependencies 2) how to for ROS to use my OpenNI2 Any reference?

Myzhar gravatar imageMyzhar ( 2014-10-23 01:49:40 -0600 )edit

I think that before recompiling I will try the precompiled version of OpenNI2 from http://structure.io/openni . My problem remains the same... see (1) and (2) from my last comment ;-)

Myzhar gravatar imageMyzhar ( 2014-10-23 01:51:57 -0600 )edit

@ahendrix I downloaded OpenNI2 source code from git and compiled it following this guide: http://jetsonhacks.com/2014/08/28/occ... I tried "SimpleRead" example, but I cannot find the sensor. So I tried running "rqt" and I can see RGB and Depth, but not the msg pointcloud2

Myzhar gravatar imageMyzhar ( 2014-10-23 16:13:20 -0600 )edit

@ahendrix, next time I run into this issue I will post something to let you know

Hansg91 gravatar imageHansg91 ( 2014-10-24 08:32:02 -0600 )edit
0

answered 2015-01-08 02:39:15 -0600

Myzhar gravatar image

I finally succeded compiling and installing OpenNI2 to my NVidia Jetson TK1. I published the guide to the website of my robotic project: http://wp.me/P3Gzlm-hc

edit flag offensive delete link more
0

answered 2014-10-22 08:39:15 -0600

paulbovbel gravatar image

updated 2014-10-22 08:39:30 -0600

How are you reading/subscribing to the data?

Are there any error or warning messages from openni2 while you're doing this?

What about in the kernel buffer (dmesg)?

edit flag offensive delete link more

Comments

I just tried to subscribe to messages using rviz. Using USB3.0 port there are not errore messages or warning on the output of the node.

I did not verify "dmesg", I will try and I will let you know.

I read somewhere that XTion has a few parameters to be tuned (e.g. hw synchronization), am I wrong?

Myzhar gravatar imageMyzhar ( 2014-10-22 08:45:22 -0600 )edit

Additional parameters - not from my experience. Maybe the usb interface, depending on your hardware.

paulbovbel gravatar imagepaulbovbel ( 2014-10-22 08:55:29 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-10-22 01:49:26 -0600

Seen: 1,162 times

Last updated: Jan 08 '15