Asus Xtion Pro Live - Failed to set priority

asked 2014-06-11 08:18:11 -0600

TSC gravatar image

updated 2014-06-11 08:18:38 -0600

Hi there,

I have an Ubuntu 13.10 system running ROS Indigo and I want to get a Asus Xtion Pro Live running in this system. Already installed indigo-openni and openni pkgs and also installed OpenNI unstable branch ( ), OpenNI2 develop branch ( ) and Primesense Sensor unstable branch ( ).

When I run roslaunch openni2_launch openni2.launch I get the following:

[ INFO] [1402491612.069490116]: Device "1d27/0601@3/6" with serial number "1207110008" connected

Warning: USB events thread - failed to set priority. This might cause loss of data...

This is not allowing me to get any data on Rviz and also doesn't allow me to run RGBDSLAM package.

I already followed the steps in these thread ( ), including the camera firmware update. Tried many combinations of changes in the UsbInterface flag (like putting the one of primesense =2 and the one from openni2 =0, and vice-versa, both equal, etc) but I'm still getting the same problem.

This is getting me things late for my MSc project, so any quick help will really by appreciated.

Thanks in advance!

NOTE: I already tried in both USB2.0 and 3.0. Also tried roslaunch openni_launch openni.launch but this one gives me a Failed to set USB interface! error!

edit retag flag offensive close merge delete



I have a same warning message. But it is no problem to use xtion. Please check fixed frame and topic on rqt_rviz.

byeongkyu gravatar image byeongkyu  ( 2014-06-11 21:39:27 -0600 )edit

Yeah! Seems it's working! Have to figure out what's the problem with RGBDSLAM then! Thanks!

TSC gravatar image TSC  ( 2014-06-12 07:57:14 -0600 )edit

I can see the same warning.

atp gravatar image atp  ( 2014-08-08 10:40:41 -0600 )edit