Ask Your Question
0

Unable to connect to move_group action server 'pickup' within allotted time

asked 2017-02-01 09:05:28 -0500

Rahndall gravatar image

Dear Ros Users, I am trying to use moveIt! but, when launching RViz, this is the error that I get:

Unable to connect to move_group action server 'pickup' within allotted time (30s)

Actually, "pickup" is not in my list, as stated when move_group is launched:

Loading 'move_group/MoveGroupCartesianPathService'...
Loading 'move_group/MoveGroupExecuteService'...
Loading 'move_group/MoveGroupKinematicsService'...
Loading 'move_group/MoveGroupMoveAction'...
Loading 'move_group/MoveGroupPlanService'...
Loading 'move_group/MoveGroupQueryPlannersService'...
Loading 'move_group/MoveGroupStateValidationService'...
Loading 'move_group/MoveGroupGetPlanningSceneService'...
Loading 'move_group/ApplyPlanningSceneService'...
Loading 'move_group/ClearOctomapService'...


  • MoveGroup using:
    • CartesianPathService
    • ExecutePathService
    • KinematicsService
    • MoveAction
    • MotionPlanService
    • QueryPlannersService
    • StateValidationService
    • GetPlanningSceneService
    • ApplyPlanningSceneService
    • ClearOctomapService

Thank you for your support!

edit retag flag offensive close merge delete

Comments

rosparam get /move_group/capabilities give me this result:

move_group/MoveGroupCartesianPathService move_group/MoveGroupExecuteService move_group/MoveGroupKinematicsService move_group/MoveGroupMoveAction move_group/MoveGroupPlanService

Rahndall gravatar imageRahndall ( 2017-02-01 09:12:18 -0500 )edit

I tried also:
rosparam get / | grep Pick
rosparam get / | grep ick

and results are empty

Rahndall gravatar imageRahndall ( 2017-02-01 09:26:31 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-02-01 09:34:18 -0500

v4hn gravatar image

The pick capability is provided by moveit_ros/manipulation and is called move_group/MoveGroupPickPlaceAction. The MoveGroupInterface used by RViz tries to connect to this capability too, in case you want to use the pick functions.

If you intentionally did not load the capability, then you should simply ignore the warning. It is not a problem as long as you don't try to use the pick functions.

edit flag offensive delete link more

Comments

Actually, it becomes a problem since RViz seems stuck waiting for this function, and no planning is allowed

Rahndall gravatar imageRahndall ( 2017-02-01 09:55:24 -0500 )edit

Ah, right, this is a big problem indeed. We do not handle this in the code at the moment, so the only way to fix this on your end it so add the PickPlaceAction capability.

Feel free to file an issue in the project repository or propose a patch. The situation there could definitely be improved...

v4hn gravatar imagev4hn ( 2017-02-01 10:57:31 -0500 )edit

I am sorry that this is becoming a sort of "chat", but the reason for remove PickPlaceAction is related to the error:

Exception while loading move_group capability 'move_group/MoveGroupPickPlaceAction': Failed to load library /opt/ros/indigo/lib/libmoveit_move_group_pick_place_capability.so

Rahndall gravatar imageRahndall ( 2017-02-02 02:04:33 -0500 )edit

The exception is a different problem/bug again. Please decide on resolving at least one of them and feel free to open an issue at the project repository for that and/or join the IRC channel to discuss this there. At least either way forward leaves the scope of answers.ros.org in my opinion.

v4hn gravatar imagev4hn ( 2017-02-02 02:58:05 -0500 )edit
1

A "simple" sudo apt-get install ros-indigo-moveit* solved it. Thank you for the support

Rahndall gravatar imageRahndall ( 2017-02-02 04:14:35 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2017-02-01 09:05:28 -0500

Seen: 3,144 times

Last updated: Feb 01 '17